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Vorwort

Willkommen zu SinuTrain for SINUMERIK Operate - Training und Programmierung
am PC.

Mit der Schulungssoftware SinuTrain for SINUMERIK Operate lernen Sie die
Steuerung 840D sl / 828D zu bedienen und zu programmieren.

SinuTrain for SINUMERIK Operate - Training und Programmierung

Diese Dokumentation unterstitzt Sie Schritt fir Schritt bei folgenden Aufgaben:
e |nstallation der Trainings-Software von DVD

e Ubertragung der Lizenz

® Starten des Programms

e Auswahl der Werkzeugmaschine

e Starten der Simulation

An wen wendet sich SinuTrain for SINUMERIK Operate?

SinuTrain for SINUMERIK Operate ist zur Aus- und Weiterbildung folgender
Zielgruppen konzipiert:

® Neueinsteiger, Umsteiger
® Ausbildungsleiter, Trainer
® Vertriebsmitarbeiter zur Kundenprasentation

® CNC-Programmierer zur Arbeitsvorbereitung
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Vorwort

Informationen

Unter dem Link Technische Dokumentation Sinumerik
(https://support.industry.siemens.com/cs/document/108464614) gibt es
Informationen zu folgenden Themen:

e Dokumentation downloaden
Weiterfihrende Links fir den Download von Dateien aus dem Siemens Industry
Online Support Portal.

e Dokumentation individuell zusammenstellen

MySupport/ Dokumentation bietet Ihnen eine Reihe von Features zur Erstellung
lhrer eigenen Maschinendokumentation.

Siehe auch MySupport/ Dokumentation
(https://support.industry.siemens.com/My/ww/de/documentation)

e Dokumentation bestellen
Hier finden Sie die aktuelle Druckschrifteniibersicht.

® Training und FAQs
Informationen zum Trainingsangebot und zu FAQs (frequently asked questions)
finden Sie iber die Seitennavigation.

Rechtsgrundlagen

Diese Software (SinuTrain™) dient zum Erstellen und Simulieren von NC
Programmen auf einem PC auf Basis der Programmiersprache DIN 66025 sowie der
Produkte ShopMill, ShopTurn und Sprachbefehle vom Typ Sinumerik™ 828D und
840D sl. Die mit der Software erstellten Programme durfen nur dann zur Fertigung
mit Werkzeugmaschinen eingesetzt werden, wenn die Software (SinuTrain/JobShop)
auf die Sinumerik angepasst wurde, auf der das erstellte Programm ablaufen soll.

Die Anpassung muss fachgerecht von autorisiertem Personal, z.B. von Siemens,
vom Werkzeugmaschinenhersteller oder vom Handler vorgenommen werden; bei der
Anpassung sind die Vorgaben von Siemens und vom Werkzeugmaschinenhersteller
zu beachten. Andernfalls kann es zu Fehlfunktionen der Werkzeugmaschine
kommen.

Im Ubrigen gelten fir die Software fiir Kunden in Deutschland die "Allgemeinen
Bedingungen zur Uberlassung von Software fiir Automatisierungs- und
Antriebstechnik an Lizenznehmer mit Sitz in Deutschland" und fiir Kunden im
Ausland die "General Licence Conditions for Software Products for Automation and
Drives for Customers with a Seat or registered Office outside of Germany".

Training und Programmierung
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Vorwort

Technical Support

Bei technischen Fragen wenden Sie sich bitte an folgende Hotline:

Europa / Afrika
Telefon +49 0911 895 7222
Fax +49 0911 895 7223
0,14 €/Min. aus dem deutschen Festnetz, abweichende Mobilfunkpreise sind
maoglich.
Internet https://www.siemens.com/automation/support-request
Amerika
Telefon +1 423 262 2522
Fax +1 423 262 2200
E-Mail mailto:techsupport.sea@siemens.com
Asien / Pazifik
Telefon +86 1064 757 575
Fax +86 1064 747 474
E-Mail mailto:support.asia.automation@siemens.com
Hinweis

Landesspezifische Telefonnummern fiir technische Beratung finden Sie im Internet:
https://www.automation.siemens.com/partner

Fragen zur Dokumentation

Bei Fragen zur Dokumentation (Anregungen, Korrekturen) senden Sie bitte ein Fax
oder eine E-Mail an folgende Adresse:

Fax +49 9131- 98 2176
E-Mail mailto:docu.motioncontrol@siemens.com
Internetadresse

http://www.cnc4you.siemens.com

Training und Programmierung
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1 Ubersicht

Die Schulungssoftware SinuTrain for SINUMERIK Operate (im folgenden SinuTrain
genannt) simuliert auf lhrem PC eine SINUMERIK 840D sl mit der Bedienoberflache
SINUMERIK Operate.

Hinweis
Lizenz

Um eine Maschine mit vollem Funktionsumfang zu starten, benétigen Sie eine
Lizenz.

Originalgetreue Darstellung und Verhalten

SinuTrain erméglicht durch die originalgetreue Darstellung von Bedientafelfront,
Maschinensteuertafel und Bedienoberflache eine reale Bedienung.

® SinuTrain beinhaltet eine Maschinensteuertafel mit spezifischen Funktionen einer
realen Steuertafel (z. B. CYCLE START, Betriebsart etc.).

® SinuTrain beinhaltet eine Bedientafel, mit der alle spezifischen Funktionen einer
realen Bedientafel genutzt werden (Hotkey etc.).

e Die Bedienoberflache entspricht der originalen Oberflache von SINUMERIK
Operate.

® Die Simulation verhalt sich identisch zu einer echten Steuerung.

Speichern und Drucken von NC-Programmen

SinuTrain bietet die Moglichkeit, selbst erstellte NC-Programme (G-Code und
Arbeitsschrittprogramme) zu speichern.

Daruber hinaus haben Sie die Moglichkeit, ein Programm, das in der
Bedienoberflache von SINUMERIK Operate gedffnet ist, auszudrucken.

Training und Programmierung
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2 Lizenzierung mit Automation License
Manager

Sie benétigen einen gultigen Lizenzschliissel, um in SinuTrain eine Maschine mit
vollem Funktionsumfang zu starten. Er ist Bestandteil von SinuTrain for SINUMERIK
Operate und wird auf einem USB-Stick ausgeliefert.

Fir die Bedienung von SinuTrain ist keine Lizenz notwendig.

Alle Bedienbereiche und Funktionen kénnen bedient werden.

Lizenz

Mit einer Lizenz (Seite 10) stehen lhnen zuséatzliche Funktionen zur Verfligung.

Hinweis
Informationen zur Lizenz
In der Readme erhalten Sie nahere Informationen zu Lizenzen.

Lizenz mit Automation License Manager Ubertragen
Voraussetzung: USB-Stick mit der zu tibertragenden Lizenz.

1. Starten Sie den Automation License Manager Uber die Ikone oder iber das
Startmendi.

Der Automation License Manager 6ffnet sich.

2. Schliel3en Sie den USB-Stick an.
Der USB-Stick wird unter "Eigener Rechner" angezeigt.

3. Markieren Sie den Eintrag "Removable Disk" auf der linken Seite.

Auf der rechten Seite sehen Sie die auf dem USB-Stick vorhandenen Lizenzen.
4. Ubertragen Sie die Lizenz mit Drag&Drop auf eine lokale Festplatte.

- ODER -

Wahlen Sie dazu im Kontextmenii der Lizenz "Ubertragen...".

5. Wabhlen Sie in dem sich 6ffnenden Fenster das Ziel der Lizenziibertragung.
Nachdem die Lizenz Uibertragen ist, erscheint diese auf dem Ziellaufwerk.

Training und Programmierung
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3 Lizenzmodell

Nutzung und Umfang von Funktionen der verschiedenen Vorlagenmaschinen sind
davon abhangig, ob Sie Uber eine Lizenz verfligen.

DEMO Maschinen

® DEMO Maschinen sind fest vorkonfigurierte Maschinen, die nicht gedndert
werden kénnen.

® Fir DEMO Maschinen benétigen Sie keine Lizenz.
® Sie haben die Mdglichkeit, die Maschinen zu starten und zu bedienen.

® Sie haben z.B. die Méglichkeit, Werkstiicke und Teileprogramme an die
Maschine zur Programmsimulation und -anpassung zu bertragen und
anschlieend zur weiteren Verwendung an CNC-Steuerungen aus der Maschine
auszuleiten.

e Ausgewahlte Funktionen stehen nicht zur Verfiigung. Weitere Informationen
finden Sie in der Hilfe zur CNC Software.

Vorlagenmaschinen / Importierte Maschinen / Aus IBN-Archiv erstellte Maschinen

® Sie haben die Méglichkeit, alle Maschinen zu starten und zu bedienen. Das
ermdglicht IThnen, alle SINUMERIK-Funktionen auszuprobieren.

® Alle Maschinen verfuigen tGber den vollen Funktionsumfang von SINUMERIK
Operate.

® Lizenz
— Ohne Lizenz

Das Ubertragen von Werkstiicken und Teileprogrammen an die bzw. aus der
Maschine ist nicht méglich.

- Mit Lizenz
Das Ubertragen von Werkstiicken und Teileprogrammen an die bzw. aus der
Maschine ist méglich.

Training und Programmierung
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Lizenzmodell

Hinweis
Lizenz nachtraglich ablegen

Falls Sie eine Lizenz ablegen, wahrend die Maschine bereits gestartet ist, fiihren Sie
einen Neustart der Maschine durch.

Erst jetzt haben Sie die Méglichkeit, die Maschine ohne Einschréankungen zu
verwenden.

Maschinen exportieren und importieren / Teileprogramme ausdrucken

Fir die Funktionen "Importieren" und "Exportieren” von Maschinen sowie das
Drucken von Teileprogrammen benétigen Sie generell eine Lizenz.

Training und Programmierung
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4 SinuTrain for SINUMERIK Operate

4.1 SinuTrain installieren / deinstallieren
4.1.1 Systemvoraussetzungen
Hardware

Prozessor: 2 GHz (SingleCore)

RAM: 4 GB

Festplatte:

e 3,3 GB fiir vollstandige Installation mit allen Sprachen
e 1,2 GB fir Minimalinstallation (Sprache Englisch)
DVD-Laufwerk: zur Installation Giber DVD-Datentrager
Grafikkarte:

® DirectX 9 oder hdher mit WDDM 1.0 Treiber

e minimale Auflésung 800x600 Pixel
USB-Schnittstelle

Maus, Tastatur

Betriebssysteme

e Windows 7 (32 Bit und 64 Bit, nicht unterstiitzt werden Starter, Web Edition und
Embedded)

e \Windows 8.1
Software
Adobe Acrobat Reader®

Training und Programmierung
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SinuTrain for SINUMERIK Operate

4.1.2 SinuTrain installieren

Das Softwareprodukt SinuTrain for SINUMERIK Operate besteht aus verschiedenen
Softwarekomponenten, die teilweise ein eigenes Setup besitzen (z. B. Automation
License Manager).

Voraussetzung

Fir das uneingeschrankte Arbeiten mit angelegten Maschinen benétigen Sie einen
Lizenzschlissel. Dieser muss vor dem ersten Start einer Maschine auf den PC
Uibertragen werden. Zu diesem Zweck wird bei der Installation von SinuTrain ein
zusatzliches Programm installiert — der Automation License Manager. Mit Hilfe des
Automation License Manager wird der Lizenzschliissel auf den PC iibertragen.

Vorgehensweise

1. Doppelklicken Sie auf die "setup.exe" im Wurzelverzeichnis der DVD.

Bei aktivierter Benutzerkontensteuerung erscheint nach einem Doppelklick auf
die "setup.exe" eine Systemabfrage. Mit dieser Abfrage stimmen Sie zu, dass das
Setup Anderungen an lhrem System vornehmen darf (diese Abfrage stammt aus
Windows und ist kein von Siemens erstellter Bestandteil). Bestatigen Sie diesen
Dialog und fahren Sie mit der Installation fort.

2. Wabhlen Sie die Setup-Sprache und klicken Sie auf die Schaltflache "Weiter >".

3. Lesen Sie die Hinweise zu Installation und Programmnutzung und klicken Sie auf
die Schaltflache "Weiter >".

4. Klicken Sie auf die Schaltflache "Liesmich" und lesen Sie den Liesmich-Text mit
den Produkthinweisen, schlieRen Sie anschlieRend die Liesmich-Datei wieder
und klicken Sie auf die Schaltflache "Weiter >".

5. Lesen Sie die Lizenzvereinbarung und aktivieren Sie anschlieRend das
Kontrollkéstchen, um die Lizenzvereinbarung und die Sicherheitshinweise zu
akzeptieren und klicken Sie auf die Schaltflache "Weiter >".

6. Wabhlen Sie die Sprachen aus, in der Sie SinuTrain for SINUMERIK Operate
installieren wollen.
Die ausgewahlten Sprachen stehen lhnen in SinuTrain sowie SINUMERIK
Operate zur Verfiigung.

7. Aktivieren Sie im Fenster "Programme" die gewiinschten Kontrollkastchen und
klicken Sie auf die Schaltflache "Weiter>".
Wenn Sie den Installationspfad der einzelnen Produkte &ndern wollen, markieren
Sie das jeweilige Produkt, klicken Sie auf die Schaltflache "Durchsuchen" und
wahlen Sie den gewiinschten Ordner.

Training und Programmierung
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SinuTrain for SINUMERIK Operate

Hinweis

Vor der Installation von SinuTrain wird unter Umstanden eine automatische
Installation von Systemaktualisierungen durchgefiihrt, die eventuell einen
Neustart des Rechners notwendig macht. Das Setup wird nach dem Neustart des
PC anschlieRend automatisch fortgesetzt.

Die Installation von SinuTrain und Automation License Manager beginnt.
Nach Beendigung der Installation von SinuTrain erhalten Sie eine entsprechende
Information.
8. Klicken Sie auf die Schaltflache "Beenden".
SinuTrain sowie Automation License Manager sind betriebsbereit.

Hinweis
Benutzerkontensteuerung

Wenn bei der Abfrage der Benutzerkontensteuerung als Herausgeber "Unbekannt”
steht, verneinen Sie die Abfrage und melden Sie sich bei der Hotline.

Alle frei gegebenen Produkte von Siemens sind mit einem Zertifikat versehen,
wodurch bei der Abfrage als Herausgeber stets die Siemens AG angegeben sein
wird.

Hinweis
Klicken Sie auf die Schaltflache "Abbrechen", um die Installation wieder zu verlassen.

Hinweis
Es wird empfohlen, die Installation nicht aus einem Netzlaufwerk heraus zu starten,

da es wegen eventuell erforderlichen Systemaktualisierungen zu Problemen
kommen kann.

4.1.3 SinuTrain deinstallieren

Vorgehensweise
1. Wabhlen Sie im Windows-Menu Start > Systemsteuerung.

2. Doppelklicken Sie in der Liste der Systemsteuerung auf "Programme und
Funktionen" (Windows 7).

3. Wahlen Sie in der Software-Liste "SinuTrain Workbench 1.2" und klicken Sie auf
die Schaltflache "Deinstallieren”.

4. Wahlen Sie in der Software-Liste die installierten Versionen von "SinuTrain
SINUMERIK CNC-SW" und klicken Sie auf die Schaltflache "Deinstallieren”.

Training und Programmierung
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SinuTrain for SINUMERIK Operate

4.2 SinuTrain bedienen

4.2.1 So funktioniert SinuTrain

Voraussetzung
SinuTrain for SINUMERIK Operate ist installiert.

Allgemeiner Ablauf

Sprache auswahlen

Beim erstmaligen Start wahlen Sie die gewiinschte Sprache fiir SinuTrain und
SINUMERIK Operate.

SinuTrain starten

Nach Bestatigung des Nutzungshinweises 6ffnet sich SinuTrain mit der
Maschinenubersicht.

Maschine anlegen

In der Maschinenubersicht legen Sie eine Maschine an.

Dabei wahlen Sie zunachst Uber Vorlagen eine Maschine des gewiinschten Typs.

AnschlieBend legen Sie Namen und Kurzbeschreibung der Maschine fest, wahlen
evtl. ein eigenes Maschinenbild fir die Maschinenibersicht und legen Auflésung
und Sprache der Maschinensimulation in der SINUMERIK Operate
Bedienoberflache fest.

Maschine starten

Die Maschinensimulation 6ffnet sich mit Bedientafel und Bedienoberflache
SINUMERIK Operate, Maschinensteuertafel mit Vorschub- und Spindeloverride
sowie CNC-Tastatur.

Maschine simulieren

Die simulierte Maschine kénnen Sie jetzt wie eine echte Maschine bedienen und
z. B. Programme erstellen.

Training und Programmierung
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SinuTrain for SINUMERIK Operate

4.2.2

Maschinenibersicht

In der Maschinenubersicht legen Sie Maschinen an, parametrieren und verwalten die

Maschinenkonfigurationen, mit denen Sie trainieren.

> o

@

Ubersiht

Neue Maschine erstellen

» Vorlage verwenden
» Maschine importieren

» IBN-Archiv einlesen

Beschreibung:

SP1-Spindel (Hauptspindel),
X-Achse (lineare Geometrieachse),
Y-Achse (lineare Geometrieachs..

mSinuTr in for SINUMERIK Operate =[-& @
SIEIAENS
C

Drehmaschine mit

angetriebenem Werkzeug, Y-
Achse und Gegenspindel

El‘tl

840D sl 4.5 SP6 HF3

DEMO-Drehmaschine

-
——

840D sl 4.7 SP3 {F1

DEMO-Frasmaschine

LT

840D sl 4.5 SP6 HF3

Vertikale Frasmaschine

840D sl 4.7 SP3 HF1

® 006

®

®

®

Funktionskachel mit Optionen zur Anlage von Maschinenkonfigurationen

SinuTrain-Menu

Maschinenibersicht mit allen angelegten Maschinen
Informationskachel mit Beschreibung der selektierten Maschinenkonfiguration
Angelegte Maschinenkonfiguration mit Maschinenname und CNC

Softwareversion

Selektierte Maschinenkonfiguration
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SinuTrain for SINUMERIK Operate

Siehe auch

Menibefehle (Seite 43)

Kontextmeni (Seite 46)

Ubersicht (Seite 22)

Maschine aus Vorlage erstellen (Seite 23)
Maschine kopieren und konfigurieren (Seite 25)
Maschine importieren (Seite 25)

Maschine aus Inbetriebnahmearchiv erstellen (Seite 28)
4.2.3 Bildschirmeinteilung der Maschinensimulation

Bedienoberflache von SinuTrain

O—

500 000
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0|

Istwerte
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s 2b ]
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N B rn --
l l HEE 0 ﬂ
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®

SinuTrain-Menu

Bedienoberflache SINUMERIK Operate

Bedienelemente einer Bedientafel

Maschinensteuertafel mit Vorschub- und Spindeloverride

DO
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SinuTrain for SINUMERIK Operate

Siehe auch
Menibefehle (Seite 43)

42.4 Sprachen installieren

4241 Zusatzliche Sprachen fiir SinuTrain installieren

Bei der Installation von SinuTrain for SINUMERIK Operate wéahlen Sie die
gewlinschte Sprache. Dabei wird die Bedienoberflache von SINUMERIK Operate in
der gewahlten Sprache mit installiert.

Folgende Standardsprachen stehen bei der Installation zur Auswahl: Deutsch,
Englisch, Franzésisch, Italienisch, Spanisch und Chinesisch vereinfacht.

SinuTrain-Sprachen nachinstallieren

Wenn Sie bei der Installation von SinuTrain eine der Standardsprachen nicht
ausgewahlt haben, kann durch ein erneutes Setup (Reparaturinstallation) die
gewiinschte Sprache nachtraglich installiert werden. Damit steht dann auch
SINUMERIK Operate in der Sprache zur Verfiigung.

4242 Zusétzliche Sprachen fir SINUMERIK Operate
installieren

Sie haben die Moglichkeit, weitere Sprachen fiir die SINUMERIK Operate
Bedienoberflache zu installieren.
Zusatzsprachen installieren

Zusétzliche Sprachpakete werden auf folgender Internetadresse zum Download
angeboten:

http://www.cncdyou.siemens.com (http://www.cncdyou.siemens.com)

Training und Programmierung
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Vorgehensweise

1. Wahlen Sie den Menubefehl Extras > HMI Zusatzsprachen installieren....
Das Fenster "HMI Zusatzsprachen installieren” 6ffnet sich.

2. Klicken Sie auf die Schaltflache "..." und navigieren Sie im Dialog "Offnen” zum
Ablageort der Sprachpakete.

3. Wabhlen Sie die gewiinschte Sprachdatei (*.slf) und klicken Sie auf die
Schaltflache "Offnen"”.

Sie kehren ins Fenster "HMI Zusatzsprachen installieren” zuriick.

Der Ablagepfad ist eingetragen. Die gewahlte Sprache wird angezeigt und mit
einem Flaggensymbol gekennzeichnet. Zuséatzlich werden die Version des
SINUMERIK Operate Sprachpakets und der Steuerungstyp angezeigt.

4. Wahlen Sie gegebenenfalls den CNC-Softwarestand, fiir den das Sprachpaket
installiert werden soll.

5. Klicken Sie auf die Schaltflache "Installieren”.
Ein Fortschrittsbalken zeigt den Installationsvorgang an.
Nach erfolgreicher Installation erhalten Sie eine Meldung.

6. Klicken Sie auf die Schaltflaiche "OK", um die Installation fertig zu stellen.

Hinweis
Sie haben die Méglichkeit, den Hinweis zur erfolgreichen Installation fiir zukiinftige

Installationen von Sprachpaketen auszuschalten. Aktivieren Sie hierfir das
Kontrollkéstchen "Diesen Hinweis nicht wieder anzeigen".

Wahlen Sie den Menubefehl Extras > Optionen und aktivieren Sie im Fenster
"Optionen" das Kontrollkastchen "Abschluss der Sprachinstallation melden”, um den
Hinweis fur zukinftige Installationen wieder einzuschalten.

Training und Programmierung
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SinuTrain for SINUMERIK Operate

4.2.5 SinuTrain-Sprache andern

Sie haben die Méglichkeit, die Sprache (Deutsch, Englisch, Franzdsisch, Spanisch,
Italienisch, Chinesisch vereinfacht) der Bedienoberflache von SinuTrain
umzuschalten.

Alle beim Setup oder nachtraglich installierten Sprachen lassen sich auswahlen.

Hinweis
SinuTrain-Sprache nachinstallieren

Haben Sie bei der Installation von SinuTrain eine der Standardsprachen nicht
ausgewahlt, haben Sie die Méglichkeit tber ein erneutes Setup
(Reparaturinstallation) die gewlinschte Sprache nachtraglich zu installieren.

Vorgehensweise
1. Wahlen Sie den Menibefehl Extras > Optionen.

2. Wabhlen Sie in der Auswabhlliste "Sprache der SinuTrain Oberflache" die
gewlinschte Sprache und klicken Sie auf "OK".

Hinweis
Sprache von SINUMERIK Operate &ndern

In SINUMERIK Operate andern Sie Uber die Tastenkombination <CTRL + L> oder im
Bedienbereich "Inbetriebnahme™ mit Hilfe des Softkeys "Change language" die
Sprache der Bedienoberflache von SINUMERIK Operate.

Siehe auch
Zusétzliche Sprachen fur SINUMERIK Operate installieren (Seite 18)
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4.3 Mit SinuTrain arbeiten

4.3.1 SinuTrain starten und beenden

SinuTrain starten

1.

2.

Wahlen Sie den Menubefehl Programme > SinuTrain for SINUMERIK Operate >
SinuTrain.

- ODER -
Doppelklicken Sie auf das Symbol fur SinuTrain auf Ihrem Desktop.

SINU
GGAIN

SinuTrain

Beim erstmaligen Start wird ein Dialog zur Auswahl der Sprache der SinuTrain-
Bedienoberflache sowie SINUMERIK Operate geoffnet.

Wahlen Sie die gewlinschte Sprache und klicken Sie auf die Schaltflache
"Weiter".

Hinweis: Es stehen Ihnen hier die Sprachen zur Verfiigung, die Sie bei der
Installation von SinuTrain ausgewahlt haben.

Ein Nutzungshinweis fiir SinuTrain for SINUMERIK Operate wird geéffnet.

Klicken Sie auf "OK", um das Programm zu starten.
Die Maschinenibersicht 6ffnet sich.

T SinuTrain for SINUMERIK Operate =

Datei Maschine Extras Fenster Hilfe

SIEMENS

Ubersicht

Neue Maschine erstellen
» Vorlage verwenden

p Maschine importieren
P IBN-Archiv einlesen
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Hinweis

Sie haben die Mdglichkeit, den Nutzungshinweis fur zukiinftige Programmstarts
auszuschalten. Aktivieren Sie hierfir das Kontrollkastchen "Diesen Hinweis nicht
wieder anzeigen".

Wahlen Sie den Menubefehl Extras > Optionen und aktivieren Sie im Fenster

"Optionen" das Kontrollkastchen "Nutzungshinweis bei Programmstart anzeigen”, um
den Hinweis furr zukiinftige Starts wieder einzuschalten.

SinuTrain beenden

e \Wahlen Sie den Menibefehl Datei > Beenden.
SinuTrain schlieft sich.

Siehe auch

Zusétzliche Sprachen fur SinuTrain installieren (Seite 18)

4.3.2 Maschine anlegen

4321  Ubersicht
Sie haben folgende Mdglichkeiten, eine Maschine anzulegen:

® Maschine aus Vorlage erstellen (Seite 23)
Grundlage sind mitgelieferte Standardkonfigurationen fir Dreh- und
Frasmaschinen.

® Maschine kopieren und konfigurieren (Seite 25)
Grundlage ist eine von Ihnen zuvor angelegte Maschinenkonfiguration, die in der
Maschinenubersicht bereits vorhanden ist.

® Maschine importieren (Seite 25)
Grundlage ist eine exportierte Maschinenkonfiguration, die Sie importieren und
modifizieren.

® Maschine aus Inbetriebnahmearchiv erstellen (Seite 28)
Grundlage ist ein Inbetriebnahmearchiv (*.arc).
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43.2.2 Maschine aus Vorlage erstellen

Voraussetzung

SinuTrain ist gestartet und die Maschinenubersicht ist gedffnet.

Maschine aus einer Vorlage erstellen

1. Klicken Sie in der Funktionskachel "Neue Maschine erstellen" auf die Option
"Vorlage verwenden".

Ubersicht

- ODER -
Wahlen Sie den Meniibefehl Datei > Neu > aus einer Vorlage....
Der Dialog "Neue Maschine erstellen - Vorlage verwenden" wird geoffnet.

Hinweis
Je nach verfuigbarer SINUMERIK Version stehen lhnen verschiedene
Vorlagenmaschinen zur Verfligung.

2. Offnen Sie die Auswahlliste "Maschinentyp” und wéhlen Sie die gewiinschte
Vorlage.

Sie haben die Mdglichkeit, in dem sich 6ffnenden Datenbaum zu jedem System
(z.B. 840D sl) die gewiinschte CNC-Software (z.B. 4.7) auszuwéahlen.

Nach der Auswahl wird im Anzeigefeld "Erstellt mit CNC-SW" System und
Software-Version der gewahlten Maschine angezeigt.

3. Geben Sie im Eingabefeld "Maschinenname" den gewunschten Namen fur die
Maschine ein (z. B. Meine Maschine).
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Geben Sie im Eingabefeld "Beschreibung" eventuell eine Kurzbeschreibung ein.
Wabhlen Sie die Auflésung der Maschinenoberflache (z. B. 1024 x 768).
Wabhlen Sie die Sprache der Maschinenoberflache (z. B. Englisch).

N oo o &

Wenn Sie fur die Darstellung der Maschine ein eigenes Maschinenbild
verwenden wollen, klicken Sie auf die Schaltflache "..." neben dem Feld "Bild
importieren", navigieren Sie im Dialog "Offnen” zum Ablageort der Grafik
(*.png,*.jpg,*.bmp) und klicken Sie auf "OK".

Sie kehren in das Fenster "Neue Maschine erstellen - Vorlage verwenden”
zuruck. Der Ablagepfad wird angezeigt.

8. Klicken Sie auf die Schaltflache "Erstellen”.

Hinweis
Wenn bereits eine Maschine mit demselben Namen vorhanden ist, erhalten Sie

einen Hinweis. Klicken Sie auf "OK" und geben Sie einen neuen
Maschinennamen ein.

In der Ubersicht wird die erstellte Maschinenkonfiguration fir
SINUMERIK 840D sl eingefugt.

Ubersicht

Meine Maschine

840D sl 4.7 SP3 HF1 o

Beschreibung:

Eine ganz einfache Maschine
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4323 Maschine kopieren und konfigurieren

Voraussetzung
® SinuTrain ist gestartet und die Maschinenubersicht ist geoffnet.

® Es sind Maschinen angelegt.

Neue Maschinenkonfiguration erstellen

1. Wahlen Sie in der Maschinenibersicht die Maschinenkonfiguration, die Sie
kopieren und firr eine weitere Maschine verwenden wollen.

2. Wahlen Sie den Menipunkt Datei > Kopieren und einfiigen.
- ODER -

Wahlen Sie aus dem Kontextmenii der rechten Maustaste "Kopieren und
einfiigen".

Die Maschine wird der Maschineniibersicht hinzugeftigt und durch eine Nummer
im Maschinennamen kenntlich gemacht.

3. Wahlen Sie anschlieend fur die kopierte Maschine den Menupunkt Maschine >
Einstellungen....

- ODER -
Wahlen Sie aus dem Kontextmenii der rechten Maustaste "Einstellungen...".
Der Dialog "Maschine bearbeiten" wird gedffnet.

4. Geben Sie die gewiinschten Anderungen ein (z. B. Maschinenname, Auflésung,
Sprache, Maschinenbild) und klicken Sie auf die Schaltflache "Speichern und
schlieen".

Siehe auch

Maschineneinstellungen andern (Seite 30)

4324 Maschine importieren

Voraussetzungen
® Sie verfiigen Uber eine Lizenz.
® SinuTrain ist gestartet und die Maschinenubersicht ist geoffnet.

® Sie haben Maschinenkonfigurationen zur Sicherung bzw. als Ausgangspunkt fir
spatere Maschinenkonfigurationen exportiert.
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Hinweis

Unterschiedliche SINUMERIK CNC-Systemsoftware-Versionen

Der SINUMERIK CNC-Systemsoftware-Stand der zu importierenden Datei steht mit
SinuTrain for SINUMERIK Operate zur Verfugung. Bei unterschiedlichen Versionen

sind nachtraglich manuelle Anderungen entsprechend den NC-Hochriistanleitungen
notig.

Maschine importieren

1. Klicken Sie in der Funktionskachel "Neue Maschine erstellen" auf die Option
"Maschine importieren".

Ubersicht

- ODER -

Wahlen Sie den Menupunkt Datei > Importieren....

Das Fenster "Neue Maschine erstellen - Maschine importieren” wird gedffnet.
2. Klicken Sie neben dem Feld "Ausgewa&hlite Datei" auf die Schaltflache "..." und

navigieren Sie im Dialog "Offnen" zum Ablageort der exportierten
Konfigurationen.

3. Wahlen Sie die gewlinschte Maschinenkonfigurationsdatei (*.set) und klicken Sie
auf die Schaltflache "Offnen".
Sie kehren in das Fenster "Neue Maschine erstellen - importieren" zurtick:
— Im Feld "Ausgewahlte Datei" wird der Ablagepfad angezeigt.

— Im Feld "Erstellt mit CNC-SW" wird angezeigt, unter welcher SINUMERIK
CNC-Software-Version und mit welchem System (z. B. 840D sl) die
Maschinenkonfiguration erzeugt wurde.
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4. Falls Sie mehrere Versionen der CNC-Software installiert haben, kdnnen Sie im
Feld "Ubernehmen in" auswahlen, fiir welchen Softwarestand die Maschine
erstellt werden soll.

5. Andern Sie bei Bedarf die gewiinschten Einstellungen (z. B. Maschinennamen,
Beschreibung etc.) und importieren Sie evtl. ein eigenes Maschinenbild.

Hinweis
Beachten Sie, dass es in der Maschinenuibersicht keine Maschinen mit
identischem Namen geben kann.

Andern Sie im Fenster "Neue Maschine erstellen - importieren" immer den
Maschinennamen, auch wenn Sie die Auspragung der Maschine nicht &ndern
wollen.

6. Wenn Sie die ausgewahlte Konfiguration zukiinftig als Vorlage fir weitere
Maschinen verwenden wollen, aktivieren Sie die Checkbox "Maschine in die Liste
der Vorlagenmaschinen tibernehmen".

7. Klicken Sie auf die Schaltflache "Erstellen”.

Hinweis
Warnhinweise und Meldungen

Treten beim Importieren der Maschinenkonfiguration Probleme auf, 6ffnet sich ein
Hinweisfenster mit entsprechenden Meldungen. Dabei werden Elemente (z. B.
Zyklen), die nicht fehlerfrei importiert wurden, mit entsprechenden
Beschreibungen aufgelistet.

Klicken Sie auf die Schaltflache "OK", um den Hinweis zu schliel3en.

Sie kehren in die Maschineniibersicht zurtick und die Maschine ist angelegt.
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4325 Maschine aus Inbetriebnahmearchiv erstellen

Beachten Sie bei der Erstellung von Maschinen aus Inbetriebnahmearchiven
folgende Bedingungen:

® SINUMERIK CNC-Systemsoftware-Stand und SinuTrain for SINUMERIK Operate
Version missen ibereinstimmen, sonst ist evtl. eine Anpassung der
Maschinenkonfiguration nicht méglich.

Hinweis
Manuelle Anpassung der Maschinenkonfiguration

Wenn eine Anpassung nicht méglich ist, sind nachtraglich manuelle Anderungen
entsprechend den NC-HochrUstanleitungen nétig.

e \Wenn Daten enthalten sind, die fur die Verwendung in SinuTrain nicht geeignet
bzw. erforderlich sind (z. B. fir PLC oder Antriebe), wird die
Maschinenkonfiguration angepasst.

Hinweis
Eine Ubersicht aller angepassten Maschinendaten finden Sie in der Online-Hilfe

zur CNC-Sofware. Wahlen Sie den Menibefehl Hilfe > Hilfe zu SINUMERIK
CNC-SW > und den entsprechenden Softwarestand.

e Das IBN-Archiv muss alle NC-Daten enthalten.

® Inbetriebnahmearchive von powerline-Systemen und HMI-Advanced / Embedded
kénnen nicht verwendet werden.

Voraussetzung

® Sie verfiigen Uber eine Lizenz.

® SinuTrain ist gestartet und die Maschinenubersicht ist geoffnet.
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Maschine aus einem Inbetriebnahmearchiv erstellen

1. Klicken Sie in der Funktionskachel "Neue Maschine erstellen" auf die Option
"IBN-Archiv einlesen".

Ubersicht

- ODER -
Wahlen Sie den Menubefehl Datei > Neu > aus einem IBN-Archiv....
Der Dialog "Neue Maschine erstellen - IBN-Archiv einlesen” wird gedffnet.
2. Klicken Sie auf die Schaltflache "..." neben dem Feld "Ausgewéhlte Datei",
navigieren Sie im Dialog "Offnen” zu dem Ablageort der gewiinschten Archiv-

Datei (*.arc), selektieren Sie die Datei und klicken Sie auf die Schaltflache
"Offnen".

Ein Hinweis-Fenster informiert Sie dartiber, dass das Archiv untersucht wird.

Sie kehren in den Dialog zuriick und die ausgewéahlte Datei wird mit dem
Verzeichnis-Pfad angezeigt.

Zusatzlich werden Steuerungstyp und Softwareversion von SINUMERIK Operate
angezeigt.
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Hinweis
Hinweismeldungen

Sie erhalten evtl. nach dem Einlesen des Inbetriebnahme-Archivs ein Fenster mit
Hinweismeldungen, die auf mégliche Fehler und Probleme hinweisen.

Sie haben die Méglichkeit, die in der Spalte "Beschreibung” eingetragenen
Zahlen Uber die Schaltflache zu kopieren, um sie dann zur Analyse an die Hotline
(Seite 3) zu senden.

3. Falls S_ie mehrere Versionen der CNC-Software installiert haben, kénnen Sie im
Feld "Ubernehmen in" auswahlen, fiir welchen Softwarestand die Maschine
erstellt werden soll.

4. Geben Sie die gewlinschten Angaben zur Maschinenkonfiguration (Name und
Beschreibung) in den entsprechenden Eingabefeldern ein, importieren Sie evtl.
ein eigenes Maschinenbild und wahlen Sie Auflésung (z. B. 1024 x 768) und
Sprache (z. B. Englisch) der Maschinenoberflache.

5. Wenn Sie das ausgewahlte Archiv zukinftig als Vorlage fir weitere Maschinen
verwenden wollen, aktivieren Sie die Checkbox "Maschine in die Liste der
Vorlagenmaschinen ibernehmen”.

6. Klicken Sie auf die Schaltflache "Erstellen”.

Hinweis
Wenn bereits eine Maschine mit demselben Namen vorhanden ist, erhalten Sie

einen Hinweis. Klicken Sie auf "OK" und geben Sie einen neuen
Maschinennamen ein.

In der Ubersicht wird die erstellte Maschinenkonfiguration eingefiigt und zeigt das
System (z. B. 840D sl) und die SINUMERIK CNC-Software-Version an.

4.3.3 Maschineneinstellungen &ndern
Sie haben die Mdglichkeit, folgende Einstellungen fur eine Maschine zu andern:

e Allgemein
— Maschinenname
— Beschreibung

® Sprache

Sprache der Maschinenoberflache (Deutsch, Englisch, Franzdsisch, Spanisch,
Italienisch, Chinesisch vereinfacht). Zur Auswahl stehen nur die Sprachen zur
Verfiigung, die bei der Installation gewahlt wurden.

Haben Sie nachtraglich Zusatzsprachen installiert, stehen diese hier ebenfalls zur
Auswahl.
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e Aufldsung
Auflésung der Maschinenoberflache
- 640x480
- 800x600
- 1024x768
- 1280x1024

® Bild importieren
Eigene Maschinenbilder kdnnen in folgenden Formaten hinterlegt werden:
- PNG
- JPG
- BMP

Vorgehensweise

1. Wabhlen Sie in der Maschinenubersicht die Maschine, fur die Sie die Einstellungen
andern wollen.
2. Wahlen Sie den Menibefehl Maschine > Einstellungen....
- ODER -
Wahlen Sie aus dem Kontextmenii der rechten Maustaste "Einstellungen...".
Der Dialog "Maschine bearbeiten" wird gedffnet.

3. Geben Sie die gewiinschten Anderungen ein und klicken Sie auf "Speichern und
schliel3en".

43.4 Maschinenkonfiguration exportieren

Sie haben die Mdglichkeit, die von Ihnen konfigurierten Maschinen zu exportieren,
um sie zu sichern. Die exportierten Maschinenkonfigurationen stehen Ihnen so als
Ausgangspunkt fir spatere Maschinenkonfigurationen oder als Sicherheitskopie zur
Verfiigung. Hierzu importieren Sie dann die gespeicherte
Maschinenkonfigurationsdatei.

Exportierte Maschinenkonfigurationen ermdglichen es Ihnen, diese zwischen zwei
Rechnern auszutauschen oder spéter in neuere SinuTrain-Versionen zu importieren.
Voraussetzung

Sie verfiigen Uber eine Lizenz.
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Vorgehensweise

1. Wahlen Sie in der Maschinenibersicht die Maschinenkonfiguration, die Sie
exportieren wollen.

2. Wahlen Sie den Menipunkt Datei > Exportieren....
- ODER -
Wahlen Sie aus dem Kontextmenii der rechten Maustaste "Exportieren...".
Der Dialog "Speichern unter" 6ffnet sich.

3. Navigieren Sie zu dem gewiinschten Ablageort, &ndern Sie bei Bedarf den
Dateinamen und klicken Sie auf die Schaltflache "Speichern".
Nach erfolgreichem Export erhalten Sie eine Meldung.

4. Klicken Sie auf die Schaltflache "OK", um den Export fertig zu stellen.

Hinweis
Sie haben die Mdglichkeit, den Hinweis zum erfolgreichen Export auszuschalten.
Aktivieren Sie hierfir das Kontrollkastchen "Diesen Hinweis nicht wieder anzeigen".

Wahlen Sie den Menubefehl Extras > Optionen und aktivieren Sie im Fenster
"Optionen" das Kontrollkastchen "Abschluss des Maschinenexports melden", um den
Hinweis fur zukinftige Exporte wieder einzuschalten.

435 Maschine l6schen

Bendbtigen Sie eine Maschinenkonfiguration nicht mehr, 16schen Sie diese aus der
Maschinenubersicht.

Vorgehensweise

1. Wahlen Sie die Maschine, die Sie aus der Liste Maschinenkonfigurationen
entfernen wollen.

2. Wahlen Sie den Menibefehl Datei > Loschen.
- ODER -
Wahlen Sie aus dem Kontextmen( der rechten Maustaste "Loschen”.

3. Bestétigen Sie den Hinweis auf den méglichen Verlust von Daten mit "OK" und

klicken Sie im anschlieBenden Nachfragedialog auf die Schaltflache "Ja", um die
Maschine zu léschen.
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Hinweis
SinuTrain-Maschine mit Anwenderdaten

Beim Ldschen einer Maschine gehen samtliche Anwenderdaten (z. B. NC-
Programme, Nullpunktverschiebungen etc.) verloren. Die Daten einer geldéschten
Maschine sind nicht wiederherstellbar.

Hinweis
Sie haben die Mdglichkeit, den Hinweis auf Datenverlust fir zukiinftige

Léschvorgange auszuschalten. Aktivieren Sie hierfir das Kontrollkastchen "Diesen
Hinweis nicht wieder anzeigen".

Wahlen Sie den Menubefehl Extras > Optionen und aktivieren Sie im Fenster
"Optionen" das Kontrollkastchen "Vor dem Léschen auf moglichen Datenverlust
hinweisen", um den Hinweis fir zukiinftige Léschvorgange wieder einzuschalten.

4.3.6 Programm ausdrucken

Sie haben die Méglichkeit, den Inhalt von Textdateien (z. B. NC-Programme) mit
einem am PC konfigurierten Drucker (lokale Drucker, Netzwerkdrucker) direkt Giber
SinuTrain aus der SINUMERIK Operate Bedienoberflache zu drucken.

Sie kénnen G-Code Programme sowie ShopMill- bzw. ShopTurn-
Arbeitsschrittprogramme mit G-Code drucken.

Layout festlegen

Im Fenster "Druckeinstellungen” legen Sie das Layout fiir den Druck fest, bestimmen
den Umfang des NC-Programms, der gedruckt werden soll, und konfigurieren die
Darstellung des Programms.

Einstellungen Auswirkung
Rander Hier definieren Sie die Seitenrander des
(mm) Links: Rechts: Ausdrucks.

Oben: Unten: Legt den Abstand zwischen oberem,

unterem, rechtem und linkem Seitenrand
und dem jeweiligen Rand der Zeilen in mm
fest.
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Einstellungen

Auswirkung

Druck- Hier legen Sie den Umfang des
bereich Programmausdrucks fest.
Alles Legt fest, dass das ganze NC-Programm
ausgedruckt wird.
Zeilen Legt die Zeilen des NC-Programms fest,
von: bis: die ausgedruckt werden.

Ausgewahlter Bereich

Legt fest, dass nur der im Editor markierte
Teil des NC-Programms ausgedruckt wird.

Programme als Text drucken

Legt fest, dass Arbeitsschrittprogramme
(ShopMill/ShopTurn) als G-Code
ausgedruckt werden.

Programme mit grafischen
Abbildungen drucken

Legt fest, dass Arbeitsschrittprogramme
(ShopMill/ShopTurn) so gedruckt werden,
wie sie im Editor erscheinen.

Programme mit
Eingabemasken
drucken

Legt fest, dass zusatzlich die
Parametermasken fir die Arbeitsschritte
ausgedruckt werden.

Zugeklappte Blécke
drucken

Legt fest, dass bei Verwendung von
Programmblécken die Programmsétze in
den Blécken mit ausgedruckt werden.

Voraussetzung
Um aus der SINUMERIK Operate Bedienoberflache zu drucken, benétigen Sie eine
Lizenz.
Vorgehensweise
1.  Wahlen Sie im Ablageverzeichnis des Programm-Managers das
E Programm, das Sie ausdrucken wollen.
Programm-—
Manager
z 2. Positionieren Sie den Cursor auf das Programm und driicken Sie
Offnen den Softkey "Offnen”.

Das Programm 6ffnet sich im Editor.
3. Wabhlen Sie den Menubefehl Datei > Druckeinstellungen... .
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4.  Geben Sie im Fenster "Druckeinstellungen” die Abstande fir die
Seitenrander ein, legen Sie den Druckbereich und die
Darstellungsform des Programms fest und klicken Sie auf die
Schaltflache "OK", um Ihre Angaben zu bestétigen.

5. Wahlen Sie den Menubefehl Datei > Drucken.

Der Dialog "Drucken" mit dem aktivierten Standard-Drucker
(lokale Drucker, Netzwerkdrucker) 6ffnet sich.

6. Klicken Sie auf die Schaltflache "Drucken”.

Je nach Festlegung des Druckbereichs wird das gesamte
Programm, eine bestimmte Anzahl von Zeilen des Programms
oder ein markierter Bereich des Programms ausgedruckt.

437 Maschine starten und herunterfahren

Voraussetzung
® |In der Maschineniibersicht stehen Maschinenkonfigurationen zur Verfiigung.

® Um den gesamten Funktionsumfang nutzen zu kénnen, benétigen Sie eine
Lizenz. Informationen zu Funktionseinschrankungen finden Sie unter
Lizenzmodell (Seite 10).

Maschine starten

Die Maschineniibersicht ist gedffnet.

1. Wahlen Sie in der Liste der Maschinenkonfigurationen die gewilinschte Maschine.
2. Wahlen Sie den Meniibefehl Maschine > Starten.

- ODER -

Wahlen Sie aus dem Kontextmen( der rechten Maustaste "Starten”.

- ODER -
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Klicken Sie auf den Pfeil in der Maschinenkonfiguration.

Meine Maschine

T

e

-
S

840D sl 4.7 SP3 HF1 Q}

Die Maschinensimulation mit Bedientafel und Bedienoberflache SINUMERIK
Operate, Maschinensteuertafel mit Vorschub- und Spindeloverride sowie CNC-
Tastatur 6ffnet sich.

3. Sie bedienen SINUMERIK Operate mit Hilfe der Maus oder einer Standard-
Tastatur.

4. Klicken Sie bei der Bedienung von SINUMERIK Operate auf die Taste <HELP>
oder driicken Sie die Taste <F12>, um sich die kontextsensitive Online-Hilfe fur
die Fenster und Eingabemasken von SINUMERIK Operate anzeigen zu lassen.

ACHTUNG

Datenverlust beim auf3erplanméafigen Beenden von Sinutrain

Wenn das Betriebssystem das Beenden von Sinutrain forciert (z. B. beim Abmelden
des aktuellen Benutzgrs), werden nur die NCK-Daten der aktuell laufenden
Maschine gesichert. Anderungen an den Einstellungen der Maschine und an den
HMI-Daten gehen verloren.

Um diesen Datenverlust zu verhindern, fahren Sie die Maschine regelméRig
herunter.

Weitere Informationen finden Sie im Abschnitt Unerwartetes Beenden von
SinuTrain (Seite 37).

Maschine herunterfahren

e Wahlen Sie den Menlbefehl Maschine > Herunterfahren, wenn Sie die aktuelle
Maschinenkonfiguration verlassen wollen.

Sie kehren in die Maschineniibersicht zurtick.
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Maschine neu starten

® Wabhlen Sie den Meniibefehl Maschine > Neu starten, wenn Sie die aktuelle
Maschinenkonfiguration zum Beispiel nach Anderungen von Maschinendaten neu
starten wollen.

Die Maschine féahrt herunter und wird anschlie3end sofort wieder hochgefahren.

4.4 Problembehandlung

4.4.1 Unerwartetes Beenden von SinuTrain

In bestimmten Situationen erzwingt das Betriebssystem das Beenden aller laufenden
Programme, z. B.:

e Beim Abmelden des aktuellen Benutzers.

® Beim Neustart des Computers nach Updates.

Falls in diesem Moment SinuTrain l&auft und eine Maschine gestartet wurde, werden
die Daten der gestarteten Maschine nur teilweise gesichert und SinuTrain beendet.

Gesicherte Daten

ACHTUNG

Datenverlust

Da SinuTrain schnellstmdglich vom Betriebssystem beendet werden muss, werden
nur die NCK-Daten der gestarteten Maschine gesichert. Anderungen an den HMI-
Daten werden nicht gespeichert.

Um alle Daten zu sichern, fahren Sie regelmafig die Maschine herunter.

Sicherungsdaten: Keine Sicherungsdaten:

e NCK-Daten e Samtliche neu hinzugekommene
Anwenderdaten im HMI-Verzeichnis

e Geanderte HMI-Einstellungen z. B.
die HMI-Sprache

Wiederherstellung der Daten

Die NCK-Daten der betroffenen Maschine werden automatisch wiederhergestellt,
sobald sich der betroffene Benutzer erneut anmeldet, SinuTrain aufruft und die
Maschine startet.

Die gewiinschten HMI-Einstellungen miissen manuell gedndert werden.
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442 SinuTrain for SINUMERIK Operate Trace

Das Programm SinuTrain for SINUMERIK Operate Trace bietet die Méglichkeit, eine
Protokollierung der nachsten SinuTrain-Sitzung zu starten. Dabei werden alle
Ereignisse, Ablaufe und Meldungen aufgezeichnet, die flr eine Fehlersuche relevant
sind.

Start des Programms

Das Programm SinuTrain for SINUMERIK Operate Trace wird im
Programmverzeichnis von SinuTrain installiert. Der Standardpfad lautet C:\Program
Files (x86)\Siemens\SinuTrain\SinuTrain Workbench\ . Starten Sie das Programm
durch Doppelklick.

Um die Aufzeichnungen zu starten, klicken Sie auf die Schaltflache "Aktivieren".

f E SinuTrain for SINUMERIK Operate Trace tﬂh_J |
Ausgabepfad: Ci\Logs |:|
|:‘ 3 |:| Anzahl der Traces behalten
l |
[ | 8 |
l ' |
Hinweis

Das Aktivieren und Deaktivieren der Funktion ist nur méglich, wenn SinuTrain vorher
beendet wurde.

Die Einstellungen fur die Traces kdnnen nur geandert werden, wenn die Funktion
deaktiviert ist.

Ablage der Daten

Nach dem Start von SinuTrain for SINUMERIK Operate Trace kdnnen Sie das
Ablageverzeichnis fur die Trace-Dateien frei wahlen.

Mit jedem neuen Start von SinuTrain wird dort ein Unterverzeichnis mit Datums- und
Zeitangabe im Namen angelegt, in das die aktuelle Trace-Datei gespeichert wird.

Zur Klarung eines Problems kann es hilfreich sein, mehrere Trace-Dateien
gleichzeitig zu analysieren. Deshalb ist die Anzahl der gespeicherten Protokolle frei
wahlbar, aber auf maximal 20 Dateien begrenzt.
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SinuTrain for SINUMERIK Operate

Hinweis
Anderungen an den Einstellungen zur Ablage der Trace-Dateien werden erst beim
nachsten Start von SinuTrain wirksam.

Das bedeutet, wenn eine bereits existierende Trace-Historie reduziert wird, bleibt die
Anzahl der Traces solange bestehen bis SinuTrain for SINUMERIK Operate Trace
aktiviert und SinuTrain gestartet wurde.

Beispiel

Es existieren bereits 12 Unterverzeichnisse mit Trace-Dateien. Die Anzahl der
Traces wird auf 3 reduziert. SinuTrain for SINUMERIK Operate Trace wird aktiviert
und SinuTrain gestartet.

Dabei werden die 10 &ltesten Trace-Dateien geldscht und ein neues
Unterverzeichnis angelegt. Nach Beendigung von SinuTrain existieren genau 3
Traces.

Systemdaten

In bestimmten Situationen bendtigt die Hotline fir die Fehleranalyse die Systemdaten
des Anwender-PCs, wie zum Beispiel die Prozessorleistung oder die
Arbeitsspeicherauslastung. Dafir ist die Schaltflache ,Systemdaten anzeigen*®
vorgesehen.

443 Trace erstellen

Sollten beim Arbeiten mit SinuTrain Probleme auftreten, haben Sie die Méglichkeit,
einen Trace zu erstellen.

Aktivieren Sie dazu das Tool "SinuTrain for SINUMERIK Operate Trace (Seite 38)".
Das Tool protokolliert dann alle Aktionen und Ereignisse der nachsten SinuTrain-
Sitzung in eine Textdatei, die Sie zur Analyse an die Hotline senden.

Randbedingungen

Das Trace-Tool kann nur aktiviert oder deaktiviert werden, wenn SinuTrain nicht
lauft.
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Vorgehensweise

1.
2.

Stellen Sie sicher, dass SinuTrain beendet wurde.

Navigieren Sie zum Installationsverzeichnis von SinuTrain (Standardpfad:
"C:\Programme (x86)\SIEMENS\SinuTrain") und &ffnen Sie den Ordner
"SinuTrain Workbench".

Doppelklicken Sie auf die Datei "sinutraintrace.exe".

Das Tool "SinuTrain for SINUMERIK Operate Trace" wird gedffnet.

In "Ablagepfad" wird der Pfad zu dem Ordner angezeigt, in dem die Trace-Datei
abgelegt wird.

Hinweis
Ablageort &ndern

Klicken Sie auf die Schaltflache "..." und navigieren Sie zu dem gewiinschten
Ablageort, klicken Sie auf die Schaltflache "Neuen Ordner erstellen”, vergeben
Sie einen Namen und klicken Sie auf die Schaltflache "OK".

Der ausgewahlte Ablagepfad wird gespeichert.

Klicken Sie auf die Schaltflache "Aktivieren".

5. Starten Sie SinuTrain und reproduzieren Sie die Schritte, die zu dem Problem

fuhrten.

. Wechseln Sie zum Trace-Tool und klicken auf die Schaltflache "Trace-Ordner"

offnen.

Kopieren Sie die im Ordner abgelegte Datei "sitrace.txt" und senden Sie diese
per Mail an den Technical Support (Seite 3) zur Analyse.

Wenn Sie das Trace-Tool deaktivieren wollen, missen Sie SinuTrain vorher
wieder beenden.

Hinweis
Informationen zu Systemdaten

Sie haben die Mdglichkeit sich mit Hilfe der Schaltflache "Systemdaten anzeigen”
Informationen zum Betriebssystem, zu den Prozessoren und zur aktuellen
Speicherbelegung anzeigen zu lassen. Uber die Schaltflache "Systemdaten in die
Zwischenablage kopieren" speichern Sie diese Daten zur Weiterleitung an die
Hotline in die Zwischenablage.
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Ergdnzende Dokumentationen

5 Erganzende Dokumentationen

5.1 Bedienhandbiicher und Trainingsanleitungen

Bei der Bedienung in SinuTrain haben Sie die Mdglichkeit, die kontextsensitive
Online-Hilfe von SINUMERIK Operate Uber die HELP-Taste zu verwenden.

Zusétzlich stehen ergédnzende und weiterfiihrende Bedienhandbiicher und
Trainingsunterlagen in sechs Sprachen (Deutsch, Englisch, Franzdsisch, Italienisch,
Spanisch, Chinesisch vereinfacht) zur Verfiigung.

Hinweis
Ist eine fremdsprachige Version eines Dokumentes nicht verfiigbar, steht Ihnen
alternativ die englische Ausgabe zur Verfligung.

Bedienanleitungen und Trainingsunterlagen

® FEinfacher Frasen mit ShopMill
— Grundlagen zu Frasen
— Handhabung des Programms
—  Schritt-fir-Schritt-Anleitungen zur Programmierung und Bearbeitung
verschiedener Beispiele
® FEinfacher Drehen mit ShopTurn
— Grundlagen zu Drehen
— Handhabung des Programms
—  Schritt-fir-Schritt-Anleitungen zur Programmierung und Bearbeitung
verschiedener Beispiele
® Frasen
— Ausfuhrliches Bedienhandbuch fiir SINUMERIK Operate auf SINUMERIK
840D sl/828D mit der Auspragung Frasen.
® Drehen
— Ausfuhrliches Bedienhandbuch fiir SINUMERIK Operate auf SINUMERIK
840D sl/828D mit der Auspragung Drehen.
® Universal

— Ausfuhrliches Bedienhandbuch fiir SINUMERIK Operate auf SINUMERIK
840D sl mit der Auspragung Universal (ohne Zyklenbeschreibungen).
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Grundfunktionen

— Ausfuhrliches Funktionshandbuch mit Beschreibung von SINUMERIK
Grundfunktionen.

Programmierhandbuch Grundlagen

— Programmierhandbuch fir Anwender mit Grundkenntnissen in Bohr-, Fras-
und Drehbearbeitungen.

— Einfache Programmierbeispiele, die auch nach DIN 66025 bekannte Befehle
und Anweisungen erlautert.

Programmierhandbuch Arbeitsvorbereitung

— Ausfuhrliches Programmierhandbuch mit Beschreibung samtlicher Parameter.

Funktionshandbuch 1SO Dialekte

— Beschreibung fir die Inbetriebnahme und Abarbeitungsmaglichkeit von
Teileprogrammen externer CNC-Systeme.

Programmierhandbuch 1SO Frasen

— Ausfuhrliche Beschreibung der Besonderheiten der Programmierung im 1SO-
Mode fiir die Ausprégung Frasen.

Programmierhandbuch 1SO Drehen

— Ausfuhrliche Beschreibung der Besonderheiten der Programmierung im 1SO-
Mode fiir die Ausprégung Drehen.
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A Anhang

A.l Menilbefehle

Zur Bedienung von SinuTrain stehen folgende Menubefehle zur Verfligung:

m SinuTrain for SINUMERIK Operate

SIEMENS
Datei Maschine Extras Fenster Hilfe
Menii Menibefehle Funktion
Datei Neu aus einer Vorlage... | Wechselt in das Fenster "Neue

Maschine erstellen - Vorlage
verwenden", zur Anlage einer neuen
Maschine.

aus einem IBN-
Archiv...

Wechselt in das Fenster "Neue
Maschine erstellen - IBN-Archiv
einlesen", zur Anlage einer neuen
Maschine.

Kopieren und einfligen

Kopiert die in der Maschinentibersicht
selektierte Maschine und fugt sie der
Liste der Maschinen hinzu.

Uber den Meniibefehl Maschine >
Einstellungen... oder "Einstellungen...’
im Kontextmeni andern Sie
anschlieend die Eigenschaften der
kopierten Maschine.

Léschen Léscht die ausgewahlte SinuTrain-
Maschine.
Importieren... Wechselt in das Fenster "Neue

Maschine erstellen - Maschine
importieren”, um abgelegte und
gesicherte Maschinen in die
Maschinenubersicht zu Gbernehmen.
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Menii

Meniibefehle

Funktion

Exportieren...

Offnet den Dialog "Speichern unter", um
Maschinenkonfigurationen aus der
Maschinenibersicht abzulegen und zu
sichern.

Druckeinstellungen...

Wechselt in das Fenster
"Druckeinstellungen”.

Hier legen Sie Seitenrander und
Druckbereich fest und wahlen die
Darstellungsform der NC-Programme
fur den Druck.

Drucken...

Druckt Programme entsprechend der
Festlegungen in "Druckeinstellungen”
aus dem Editor des SINUMERIK
Operate.

Hinweis:

Nur bei gestarteter Maschine aktiv.

Beenden

Beendet SinuTrain for SINUMERIK
Operate.

Maschine

Starten

Startet die in der Maschinentibersicht
gewahlte Maschinenkonfiguration.

Neu starten

Fahrt die SinuTrain-Maschine herunter
und startet sie anschlieBend wieder
automatisch.

Herunterfahren

Fahrt die SinuTrain-Maschine herunter.
Die Maschineniibersicht bleibt gedffnet.

Einstellungen...

Wechselt in das Fenster "Maschine
bearbeiten", um Maschinennamen,
Beschreibung, Sprache und
Maschinenbild sowie die Aufldsung der
SINUMERIK Operate Oberflache zu
andern.

Extras

HMI Zusatzsprachen
installieren...

Wechselt in das Fenster "HMI
Zusatzsprachen installieren”, um
zusatzliche verfiigbare Sprachen fiir
SINUMERIK Operate zu installieren.
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Menii Meniibefehle

Funktion

Optionen...

Wechselt in das Fenster "Optionen”, um
folgende Einstellungen vorzunehmen:

e Wabhl der Sprache der SinuTrain
Oberflache

e Aktivieren bzw. deaktivieren von
Hinweismeldungen in SinuTrain for
SINUMERIK Operate (z.B. Hinweis
auf mdglichen Datenverlust beim
Léschen einer SinuTrain-Maschine)

Fenster In Einzelfenster aufteilen

Teilt das Fenster der

Maschinensimulation in 3 einzeln

verschiebbare Fenster:

e Bedienoberflache SINUMERIK
Operate

e Bedienelemente einer Bedientafel

e Maschinensteuertafel mit Vorschub-
und Spindeloverride

Hinweis:

Nur bei gestarteter Maschine aktiv.

Hilfe Hilfe zu SinuTrain...

Offnet die Online-Hilfe fir SinuTrain for
SINUMERIK Operate.

Hilfe zu SINUMERIK CNC-

Offnet die Online-Hilfe fir die

SW relaesespezifischen Informationen.
Die Untermendis sind abhangig von den
installierten CNC-Softwarestanden.
Info... Wechselt in das Fenster "Uber

SinuTrain for SINUMERIK Operate", in
dem Sie folgende Informationen
erhalten:

e Produktversion des installierten
SinuTrain for SINUMERIK Operate

e Im Bereich "Installierte SINUMERIK
CNC-SW Pakete" Angabe der
Versionen aller CNC- Software
Pakete
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A.2 Kontextmentu

In der Maschinentbersicht steht Ihnen fir jede Maschinenkachel ein Kontextmeni
mit folgenden Befehlen zur Verfligung:

Mentibefehle Funktion

Starten Startet die in der Maschineniibersicht gewahlte
Maschinenkonfiguration.

Exportieren... Offnet den Dialog "Speichern unter", um

Maschinenkonfigurationen aus der Maschineniibersicht zu
exportieren.

Kopieren und einfligen

Kopiert die in der Maschineniibersicht selektierte
Maschine und fiigt Sie der Liste der Maschinen hinzu.

Uber den Meniibefehl Maschine > Einstellungen... oder
"Einstellungen..." im Kontextmeni andern Sie
anschlieRend die Eigenschaften der kopierten Maschine.

Loschen

Léscht die ausgewahlte SinuTrain-Maschine.

Einstellungen...

Wechselt in das Fenster "Maschine bearbeiten", um
Maschinennamen, Beschreibung, Sprache und
Maschinenbild sowie die Aufldsung der SINUMERIK
Operate Oberflache zu &ndern.
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A.3 Bedienung mit PC-Standardtastatur

Zur Bedienung von SinuTrain SINUMERIK Operate stehen folgende Tasten und
Tastenkombinationen zur Verfiigung.

PC-Tastatur

Funktion

<F1> ... <F8>

Horizontale Softkeys 1 bis 8

Shift + <F1> ... <F8>

Vertikale Softkeys 1 bis 8

<F9>

AN

Shift + <F9>
<F10>
MENU
SELECT
Shift + <F10> —
M,
MACHINE
<F11> 1...n
CHANNEL
<F12> @
HELP
<Bild >
=l
PAGE
up
<Bild >
=
PAGE
DOWN
<Enter>

INPUT
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PC-Tastatur

Funktion

<Einfg>

>

INSERT

Ziffernblock <5>

O

SELECT

<Esc> =
N4
ALARM
CANCEL
<Strg> + <Alt> + <Shift> + MWy
<> UL

JOG

<Strg> + <Alt> + <Shift> +

Die laufende SinuTrain-Maschine wird

<5>

<2> heruntergefahren.
<Strg> + <Alt> + <Shift> +
<3> //
RESET
<Strg> + <Alt> + <Shift> +
<4>
CYCLE
START
<Strg> + <Alt> + <Shift> + ©

CYCLE
STOP

<Strg> + <Alt> + <Shift> +
<6>

MDA

<Strg> + <Alt> + <Shift> +
<7>

B)

SINGLE
BLOCK

<Strg> + <Alt> + <Shift> +
<8>

AUTO
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SIEMENS

SINUMERIK
SinuTrain for SINUMERIK Operate
Training and Programming

Compact User Manual

Preface

Welcome to the SinuTrain for SINUMERIK Operate - Training and programming at
the PC.

The training software SinuTrain for SINUMERIK Operate teaches you how to operate
and program the 840D sl control system / 828D.

SinuTrain for SINUMERIK Operate - Training and programming

This documentation supports you step-by-step for the following tasks:

e |nstalling the training software from DVD

® Transferring the license

® Starting the program

® Selecting the machine tool

® Starting simulation

What groups does SinuTrain for SINUMERIK Operate address?

SinuTrain for SINUMERIK Operate is designed for basic and further training of the
following target groups:

® First time users, users changing over from a different system
® Training managers, trainers
® Sales personnel for customer presentations

® CNC programmer for work preparation

© Siemens AG 2015 - 2016. All rights reserved
A5E38756522, 07/2016 51



Preface

Information

Information on the following topics is available under the link Technical Sinumerik
documentation (https://support.industry.siemens.com/cs/ww/en/view/108464614):

e Downloading documentation
Links to more information for downloading files from the Siemens Industry Online
Support Portal.

® Compile customized documentation

MySupport/ Documentation provides you with a range of features for generating
your own machine documentation.

See also MySupport/ Documentation
(https://support.industry.siemens.com/My/ww/en/documentation)

® Ordering documentation
Here you can find an up-to-date overview of publications.

® Training and FAQs
Information on our range of training courses and FAQs (frequently asked
questions) is available via the page navigation.

Legal basics

This software (SinuTrain™) is used to generate and simulate NC programs on a PC
based on the DIN 66025 programming language as well as the ShopMill, ShopTurn
and language commands, type Sinumerik™ 828D and 840D sl. The programs
generated with the software must only be used on machine tools for production if the
software (SinuTrain/JobShop), on which the generated program should run, has
been adapted to Sinumerik.

This adaptation must be professionally performed by authorized personnel, e.g. by
Siemens, by machine tool OEMs or by dealers; when carrying out any adaptation
work, the specifications of Siemens and the machine tool OEM must always be
carefully observed. Otherwise, the machine tool could malfunction.

Otherwise, for customers in Germany, the "Allgemeinen Bedingungen zur
Uberlassung von Software fir Automatisierungs- und Antriebstechnik an
Lizenznehmer mit Sitz in Deutschland" applies for the software and for customers
outside Germany "General License Conditions for Software Products for Automation
and Drives for Customers with a Seat or Registered Office outside of Germany".
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Preface

Technical Support

If you have any technical questions, please contact our hotline:

Europe / Africa
Phone +49 (0)911 895 7222
Fax +49 (0)911 895 7223
0.14 €/min from the German landline; cell phone charges may vary.
Internet ‘ https://www.siemens.com/automation/support-request
Americas
Phone +1 423 262 2522
Fax +1 423 262 2200
E-mail mailto:techsupport.sea@siemens.com
Asia / Pacific
Phone +86 1064 757 575
Fax +86 1064 747 474
E-mail mailto:support.asia.automation@siemens.com
Note

Country-specific telephone numbers for technical support are provided under the
following Internet address:

https://www.automation.siemens.com/partner

Questions about the manual

If you have any queries (suggestions, corrections) in relation to this documentation,
please fax or e-mail us:

Fax +49 9131- 98 2176
E-mail mailto:docu.motioncontrol@siemens.com

Internet address

http://www.cnc4you.siemens.com
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1 Overview

The SinuTrain for SINUMERIK Operate training software (called SinuTrain in the
following) simulates a SINUMERIK 840D sl with the SINUMERIK Operate user
interface on your PC.

Note
License
You require a license to start a machine using the full functional scope.

True to original representation and behavior

As a result of the true to original representation of the operating panel front, machine
control panel and user interface, SinuTrain facilitates real operation.

® SinuTrain includes a machine control panel with specific functions of a real
control panel (e.g. CYCLE START, operating mode etc.).

® SinuTrain includes an operator panel, with which all of the specific functions of a
real operator panel can be used (hotkey etc.).

® The user interface corresponds to the original interface of SINUMERIK Operate.

® The simulation behaves in precisely the same way as a real control.

Saving and printing NC programs

SinuTrain offers the option of saving the NC programs that you have created (G code
and machining step programs).

You also have the option of printing out a program which is open in the user interface
of SINUMERIK Operate.
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2 Licensing using the Automation License
Manager

You require a valid license key to start a machine with the full functional scope in
SinuTrain. It is an integral part of SinuTrain for SINUMERIK Operate, and is supplied
on a USB stick.

A license is not required to use SinuTrain.

All operating areas and functions can be operated.

License

Additional functions are available with a license (Page 58).

Note
Information on the license
More detailed information on licenses is available in the readme.

Transferring the license using the Automation License Manager

Precondition: USB stick with the license to be transferred.

1. Start the Automation License Manager via the icon or from the Start menu.
The Automation License Manager opens.

2. Insert the USB stick.
The USB stick is displayed under "Own computer".

3. Select the entry "Removable Disk" on the lefthand side.
On the right-hand side you can see the available licenses on the USB stick.
4. Transfer the license by dragging and dropping it onto the local hard disk.
-OR -
Select “Transfer” in the shortcut menu of the license.

5. In the window that opens, select where the license should be transferred to
(target).
After the license has been transferred, this is shown on the target drive.
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3 License model

The usage and scope of functions provided by the various template machines
depends on the availability of a license.

DEMO machines

® DEMO machines are preconfigured machines that cannot be changed.
® You do not require a license for DEMO machines.

® You can start and operate the machines.

® You can, for example, transfer workpieces and part programs to the machine for
program simulation and customization, and then from the machine for further use
on CNCs.

® Selected functions are not available. You can find additional information in the
help for the CNC software.

Template machines / imported machines / machines created from the start-up
archive

® You can start and operate all machines. This makes it possible for you to try all
SINUMERIK functions.

e All machines have the full functional scope of SINUMERIK Operate.

® License
— Without license

The transfer of workpieces and part programs to or from the machine is not
possible.

— With license

The transfer of workpieces and part programs to or from the machine is
possible.

Note
Importing a license subsequently

If you import a license when the machine has already been started, this causes a
restart.

Only then is it possible to use the machine without restrictions.

Exporting and importing machines / printing part programs

You generally require a license for the "Import" and "Export" functions of machines as
well as for the printing of part programs.
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4 SinuTrain for SINUMERIK Operate
4.1 Installing / uninstalling SinuTrain

4.1.1 System requirements

Hardware

Processor: 2 GHz (single core)

RAM: 4 GB

Hard disk:

e 3.3 GB for complete installation with all languages
e 1.2 GB for minimal installation (language English)
DVD drive: For installation using DVD data storage medium
Graphic card:

® DirectX 9 or higher with WDDM 1.0 driver

® minimum resolution 800x600 pixel

USB interface

Mouse, keyboard

Operating systems

® Windows 7 (32-bit and 64-bit, Starter, Web Edition and Embedded are not
supported)

® \Windows 8.1
Software
Adobe Acrobat Reader®
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4.1.2 Installing SinuTrain

The SinuTrain for SINUMERIK Operate software product comprises various software
components that in some cases have their own setup (e.g. Automation License
Manager).

Precondition

You require a license key to start and work with machines that have been created.
This key must be transferred to the PC before starting a machine for the first time.
When installing SinuTrain, an additional program is installed for this purpose - the
Automation License Manager. The license key is transferred to the PC using the
Automation License Manager.

Procedure

1. Double-click the "setup.exe" in the root directory of the DVD.

When the user account control is activated, after double-clicking the "setup.exe”,
a system prompt appears. With this prompt, you agree that setup can make
changes to your system (this prompt comes from Windows and is not a
component created by Siemens). Confirm this dialog and continue with the
installation.

2. Select the setup language and click the "Next >" button.

3. Read the notes on the installation and usage of the program and click the "Next
>" putton.

4. Click the "Readme" button to read the readme text with the product notes, then
close the readme file and click the "Next >" button.

5. Read the license agreement and then activate the checkbox to accept the
licensing agreement and the safety instructions and click the "Next >" button.

6. Select the languages in which you wish to install SinuTrain for SINUMERIK
Operate .
The selected languages are available in SinuTrain as well as SINUMERIK
Operate.

7. In the "Programs" window, activate the required checkbox and click the "Next>"
button.
If you want to change the installation path of the individual products, select the
specific product, click the "Browse" button and select the required folder.
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Note

Before installing SinuTrain, under certain circumstances, system updates are
automatically installed, which may make it necessary to restart the computer.
Setup is automatically continued after the PC restarts.

The installation of SinuTrain and Automation License Manager then starts.
You receive an appropriate message after completing the installation of
SinuTrain.

8. Click the "Exit" button.
SinuTrain and the Automation License Manager are ready.

Note
User account control system

When querying the user account control, if "unknown" is specified as the supplier,
respond with No and contact the hotline.

All Siemens products released have a certificate, where Siemens AG is always
specified when querying the supplier.

Note
Click the "Cancel" button to exit the installation.

Note

We recommend that the installation is not started from a network drive. This is
because problems can be encountered as a result of possible necessary system
updates.

4.1.3 Uninstalling SinuTrain

Procedure
1. Inthe Windows menu, select Start > Control Panel.

2. Double-click "Programs and functions" in the list of the Control Panel (Windows
7).

3. In the software list, select "SinuTrain Workbench 1.2" and click the "Uninstall"
button.

4. In the software list, select the installed versions of "SinuTrain SINUMERIK CNC-
SW" and click the "Uninstall" button.
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4.2 Operating SinuTrain

4.2.1 This is how SinuTrain functions

Precondition
SinuTrain for SINUMERIK Operate has been installed.

General sequence

62

Selecting a language

Select the required language for SinuTrain and SINUMERIK Operate at the first
start.

Starting SinuTrain

After confirming the Terms of Use, SinuTrain opens with the machine overview.

Creating a machine
Create a machine in the machine overview.
First select a machine of the required type using templates.

Then specify the name and brief description of the machine, if required, select
your own machine image for the machine overview and specify the resolution and
language of the machine simulation in the SINUMERIK Operate user interface.

Starting a machine

The machine simulation opens with operator panel and SINUMERIK Operate
user interface, machine control panel with feedrate and spindle override and CNC
keyboard.

Simulating a machine

You can now operate the simulated machine just like a real machine and
generate programs, for example.
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4.2.2 Machine overview

In the machine overview, you create machines and parameterize and manage the
machine configurations with which you train.

@

® ?

m SinuTr|in for SINUMERIK Operate

SIEIMENS

Overvidw

Create new machine

» Use template
» Import machine

» Read setup archive

Description:

SP1-spindle (main spindle),
X-axis (linear geometry axis),
Y-axis (linear geometry axis),

e Wi G Winiows i I

Lathe with driven tool, Y axis
and counter spindle

El‘&l

840D sl 4.5 SP6 HF3

DEMO-Lathe

-

&
—
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DEMO-Milling machine
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840D sl 4.5 SP6 HF3

Vertical milling machine

840D sl 4.7 SP3 HF1

®

SinuTrain menu
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S

Machine overview with all created machines
Information page with a description of the selected machine configuration

Created machine configuration with machine name and CNC software version
Selected machine configuration
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See also

Menu commands (Page 89)
Context menu (Page 92)
Overview (Page 69)

Creating a machine from a template (Page 70)

Copying and configuring a machine (Page 72)

Importing a machine (Page 72)

Creating a machine from the start-up archive (Page 74)

4.2.3 Screen layout of the machine simulation

User interface of SinuTrain
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Training and Programming
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e
®
@®  SinuTrain menu
@ SINUMERIK Operate user interface
®  Operator controls of an operator panel
@  Machine control panel with feedrate and spindle override
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See also

Menu commands (Page 89)

42.4 Installing languages

4241 Installing additional languages for Sinutrain

Select the required language when installing SinuTrain for SINUMERIK Operate. The
user interface of SINUMERIK Operate is also installed with the selected language.

The following standard languages are available for selection during the installation:
English, German, French, Italian, Spanish and simplified Chinese.
Subsequent installation of SinuTrain languages

If you have not selected one of the standard languages during the installation of
SinuTrain, you can install the required language subsequently by performing the
setup (repair installation) again. SINUMERIK Operate is then also available in the
language.

4242 Installing additional languages for SINUMERIK Operate
You can install further languages for the SINUMERIK Operate user interface.

Installing additional languages

Additional language packages are offered for download at the following Internet
address:

http://www.cncdyou.siemens.com (http://www.cncdyou.siemens.com)

Procedure

1. Select the Tools > Install additional HMI languages... menu command.
The "Install additional HMI languages" window opens.

2. Click the "..." button and navigate in the "Open" dialog to the storage location of
the language packages.
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3. Select the required language file (*.slf) and click the "Open" button.
You return to the "Install additional HMI languages" window.

The storage path has been entered. The selected language is displayed and
marked with a flag icon. In addition, the version of the SINUMERIK Operate
language package and the control type are displayed.

4. If necessary, select the CNC software release for which the language package
should be installed.

5. Click the "Install" button.
A progress bar shows the installation process.
You receive a message after successful installation.

6. Click the "OK" button to complete the installation.

Note

After the message regarding successful installation, you have the option of disabling
future installations of language packages. To do this, activate the "Do not display this
note again" checkbox.

Select the Tools > Options menu command and activate the "Report completion of
the language installation" checkbox in the "Options" window in order to switch the
message on again for future installations.

4.2.5 Changing the SinuTrain language

You have the option of changing over the language (German, English, French,
Spanish, Italian, Chinese simplified) of the SinuTrain user interface.

All languages installed during the setup or those subsequently installed can be
selected.

Note
Subsequent installation of SinuTrain languages

If you have not selected one of the standard languages during the installation of
SinuTrain, you can install the required language subsequently by performing the
setup (repair installation) again.

Procedure
1. Select the Tools > Options menu command.

2. Select the required language in the "Language of the SinuTrain user interface"
drop-down list and click "OK".
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Note
Changing the language of SINUMERIK Operate

In SINUMERIK Operate you can change the language of the SINUMERIK Operate
user interface using the key combination <CTRL + L> or in the "Commissioning"
operating area, using the "Change language" softkey.

See also

Installing additional languages for SINUMERIK Operate (Page 65)

4.3 Working with SinuTrain

43.1 Starting and exiting SinuTrain

Starting SinuTrain

1. Select the Programs > SinuTrain for SINUMERIK Operate > SinuTrain menu
command.
-OR -
Double-click the SinuTrain icon on your desktop.

SINU
GGAIN

SinuTrain

At the first start, the dialog for the selection of the language for the SinuTrain user
interface and SINUMERIK Operate opens.
2. Select the required language and click "Next".

Note: The languages are available that you selected during the installation of
SinuTrain.

The Terms of Use for SinuTrain for SINUMERIK Operate open.
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3. Click "OK" to start the program.
The machine overview opens.

SIEMENS

File Machine Extras Windows Help

Overview

Note

You can deactivate the Terms of Use for future program starts. To do this, activate
the "Do not display this note again" checkbox.

Select the Extras > Options menu command and activate the "Display Terms of Use
at program start" checkbox in the "Options" window in order to switch the message
on again for future starts.

Exiting SinuTrain

e Select the File > Exit menu command.
SinuTrain closes.

See also
Installing additional languages for Sinutrain (Page 65)
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4.3.2 Creating a machine

4321 Overview
You have the following options when creating a machine:

® Creating a machine from a template (Page 70)
The standard configurations supplied for lathes and milling machines form the
basis.

® Copying and configuring a machine (Page 72)
The basis is a machine configuration that you created, which already exists in the
machine overview.

® Importing a machine (Page 72)
The basis is an exported machine configuration, which you import and modify.

® Creating a machine from the start-up archive (Page 74)
The basis is a start-up archive (*.arc).
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43.2.2 Creating a machine from a template

Requirement

SinuTrain has been started and the machine overview is open.

Creating a machine from a template

1.

4,

70

Click the "Use template" option in the "Create new machine" functions page.

Overview

-OR -
Select the File > New > From a template... menu command.
The "Create new machine - Use template” dialog opens.

Note

Various template machines are available depending on the available SINUMERIK
version.

Open the "Machine type" drop-down list and select the required template.

You can select the required CNC software (e.g. 4.7) in the data tree that opens
for each system (e.g. 840D sl).

After selection, the system and software version of the selected machine is
displayed in the "Created with CNC SW" field.

In the "Machine name" entry field, enter a name for the machine (e.g. My
machine).

If required, enter a short description in the "Description” entry field.
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5. Select the resolution for the machine user interface (e.g. 1024 x 768).
6. Select the language for the machine user interface (e.g. English).

7. 1f you want to use your own machine image for the machine display, click the "..."
button next to the "Import image" field, navigate in the "Open" dialog to the
storage location of the graphic (*.png,*.jpg,*.bmp) and click "OK".

You return to the "Create new machine - Use template" window. The storage path
is displayed.

8. Click the "Create" button.

Note

If a machine with this name already exists, a corresponding message is
displayed. Click "OK" and enter a new machine name.

The machine configuration for the SINUMERIK 840D sl is inserted in the
overview.

Overview

My machine

840D sl 4.7 SP3 HF1 o

Description:

A simple machine
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43.23 Copying and configuring a machine

Requirement
® SinuTrain has been started and the machine overview is open.

® Machines have been created.

Creating a new machine configuration

1. In the machine overview, select the machine configuration that you want to copy
and use for another machine.

2. Select the File > Copy and Paste menu command.
-OR -
Right-click and select “Copy and Paste" from the shortcut menu.

The machine is added to the machine overview and identified by a number in the
machine name.

3. Then select the Machine > Settings... menu command for the copied machine.
-OR -
Right-click and select "Settings..." from the shortcut menu.
The "Edit machine" dialog opens.

4. Enter the desired changes (e.g. machine name, resolution, language, machine
image) and click "Save and close".

See also

Changing machine settings (Page 77)

4324 Importing a machine

Requirements
® You have alicense.
® SinuTrain has been started and the machine overview is open.

® You have exported machine configurations as backup or as starting point for
subsequent machine configurations.
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Note
Different SINUMERIK CNC system software versions

The SINUMERIK CNC system software version of the file to be imported is available
with SinuTrain for SINUMERIK Operate . With different versions, manual changes
must be made subsequently in accordance with the NC upgrade instructions.

Importing a machine
1. Click the "Import machine" option in the "Create new machine" functions page.

Overview

-OR -
Select the File > Import... menu command.
The "Create new machine - Import machine" window opens.

2. Click the "..." button next to the "Selected file" field and navigate in the "Open"
dialog to the storage location of the exported configurations.

3. Select the required machine configuration file (*.set) and click the "Open" button.
You return to the "Create new machine - Import" window.
— The storage path is shown in the "Selected file" field.

— The "Created with CNC SW" field shows the SINUMERIK CNC software
version and the system (e.g. 840D sl) with which the machine configuration
has been created.

4. If you have installed several versions of the CNC software, in field "Accept in",
select for which software release the machine should be created.
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5. Change the required settings as needed (e.g. machine name, description, etc.)
and import your own machine image if applicable.

Note

Note that machines with identical names are not permitted in the machine
overview.

Always change the machine name in the "Create new machine - Import" window
even if you do not want to change the type of machine.

6. If you want to use the selected configuration as a template for other machines in
the future, check the checkbox "Accept machine in the list of template machines".

7. Click the "Create" button.

Note
Warning notices and messages

If problems occur when importing the machine configuration, a window opens
with the appropriate messages. Elements (e.g. cycles) that have not been
imported error-free are listed with the appropriate descriptions.

Click "OK" to close the window.

You return to the machine overview and the machine is created.

4325 Creating a machine from the start-up archive
Note the following conditions when creating machines from start-up archives.

® SINUMERIK CNC system software version and SinuTrain for SINUMERIK
Operateversion must match, otherwise it may not be possible to adapt the
machine configuration.

Note
Manual adaptation of the machine configuration

If an adaptation is not possible, manual changes must be made subsequently in
accordance with the NC upgrade instructions.
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e |f data is contained which is not suitable or not required for use in SinuTrain (e.g.
for the PLC or drives), the machine configuration is adapted.

Note

An overview of all adapted machine data can be found in the online help for the
CNC software. Select the menu command Help > Help for SINUMERIK CNC SW
> and the corresponding software version.

® The setup archive must contain all NC data.

® Start-up archives from powerline systems and HMI-Advanced/Embedded cannot
be used.

Requirement

® You have alicense.

® SinuTrain has been started and the machine overview is open.

Creating a machine from a setup archive

1. Click the "Read setup archive" option in the "Create new machine" functions
page.

Overview

-OR -
Select the File > New > From a setup archive... menu command.
The "Create new machine - Read setup archive" dialog opens.
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2. Click the "..." button next to the "Selected file" field and navigate in the "Open"
dialog to the storage location of the required archive file (*.arc), select the file and
click "Open".

A message informs you that the archive is being checked.
You return to the dialog and the selected file is displayed with the directory path.

The control type and software version of SINUMERIK Operate are also displayed.

Note
Notice messages

After the setup archive is imported, you will get a window with informational
messages, which point out possible errors and problems.

You have the capability of copying the figures entered in the "Description” column
via the button and to then send them to the hotline (Page 51) for analysis.

3. If you have installed several versions of the CNC software, in field "Accept in",
select for which software release the machine should be created.

4. Enter the required specifications for the machine configuration (name and
description) in the corresponding entry fields, if required, import your own
machine image and select the resolution (e.g. 1024 x 768) and language (e.g.
English) of the machine user interface.

5. If you want to use the selected configuration as a template for other machines in
the future, check the checkbox "Accept machine in the list of template machines".

6. Click the "Create" button.

Note

If a machine with this name already exists, a corresponding message is
displayed. Click "OK" and enter a new machine name.

The created machine configuration is inserted in the overview, and the system
(e.g. 840D sl) and the SINUMERIK CNC software version are displayed.
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4.3.3 Changing machine settings
You can change the following settings for a machine:

® General
— Machine name
— Description

® [anguage
Machine interface language (German, English, French, Spanish, Italian, simplified
Chinese). Only the languages selected during installation are available for
selection.

If you have subsequently installed additional languages, these are also available
for selection.
® Resolution
Resolution of the machine interface
- 640x480
- 800x600
- 1024x768
- 1280x1024
® |mporting an image
Your own machine images can be stored in the following formats:
- PNG
- JPG
- BMP

Procedure

1. Inthe machine overview, select the machine for which you want to change the
settings.
2. Select the Machine > Settings... menu command.
-OR -
Right-click and select "Settings..." from the context menu.
The "Edit machine" dialog opens.

3. Enter the required changes and click "Save and close".
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43.4 Exporting a machine configuration

You have the option of exporting machines that you have configured in order to back
them up. The exported machine configurations are available as a starting point for
later machine configurations or as a back-up copy. To do this, import the saved
machine configuration file.

Exported machine configurations allow you to exchange these between two
computers or to subsequently import them into more recent SinuTrain versions.

Requirement

You have a license.

Procedure

1. Inthe machine overview, select the machine configuration that you want to
export.

2. Select the File -> Export menu command.
-OR -
Right-click and select "Export..." from the context menu.
The "Save as" dialog opens.

3. Navigate to the desired storage location, if required, change the file name and
click "Save".
You receive a message after a successful export.

4. Click "OK" to finish the export.

Note

You can deactivate the message for the successful export. To do this, activate the
"Do not display this note again" checkbox.

Select the Tools > Options menu command and activate the "Report completion of
the machine export" checkbox in the "Options" window in order to switch the
message on again for future exports.
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4.3.5 Deleting a machine

If you do not require a machine configuration any longer, delete it from the machine
overview.

Procedure

1. Select the machine that you want to remove from the Machine configuration list.

2. Select the File > Delete menu command.
-OR -
Right-click and select "Delete” from the context menu.

3. Confirm the message regarding the possible loss of data with "OK" and click in
the subsequent prompt dialog box the "Yes" button to delete the machine.

Note
SinuTrain machine with user data

When deleting a machine, all user data (e.g. NC programs, work offsets, etc.) are
lost. The data associated with a deleted machine cannot be restored.

Note

You have the option of disabling the message regarding data loss for future delete
operations. To do this, activate the "Do not display this note again" checkbox.

Select the Tools > Options menu command and activate the "Inform of possible data
loss before deleting” checkbox in the "Options" window in order to switch the
message on again for future deletions.

4.3.6 Printing-out a program

You can print out the contents of text files (e.g. NC programs) using a printer
configured on the PC (local printer, network printer) directly via SinuTrain from the
SINUMERIK Operate user interface.

You can print G code programs as well as ShopMill and ShopTurn machining step
programs with G code.
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Defining the layout

In the "Print settings" window, you specify the layout for the printing, define the scope
of the NC program that is to be printed and configure the display of the program.

Settings Effect
Margins Here you define the margins of the printout.
(mm) Left: Right: Defines the distance between the top,
Top: Bottom: bottom,. right and left mgrgin.and the
respective edge of the lines in mm.
Print Here you define the scope of the program
area printout.
Everything Defines that the complete NC program is
printed.
Lines Defines the lines of the NC program that
from: to: are to be printed.

Selected range

Defines that only the part of the NC
program marked in the editor is to be
printed.

Print programs as text

Defines that sequence programs
(ShopMill/ShopTurn) are printed out as G
code.

Print programs with graphical

illustrations

Defines that machining step programs
(ShopMill/ShopTurn) will be printed in the
same way as they appear in the editor.

Print programs with
input screen

Defines that the parameter screens for the
machining steps are also printed out.

Print closed blocks

Defines that when using program blocks,
the program sets in the blocks are also
printed.

Requirement

You require a license to print from the SINUMERIK Operate user interface.
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Procedure
1. Inthe archive folder of the program manager, select the program
E that you wish to print out.
Program
manager

2. Place the cursor on the program and press the "Open" softkey.

Open The program opens in the editor.

3. Select the File > Print settings... menu command.

Enter the distances for the margins in the "Print settings" window,
define the print range and the representation type of the program
and click the "OK" button to confirm your entries.

6. Select the File > Print menu command.

The "Print" dialog box with the activated standard printer opens
(local printer, network printer).

7. Click the "Print" button.

Depending on the print range that has been defined, the complete
program, a certain number of lines of the program or a selected
range of the program is printed.

4.3.7 Starting and shutting down a machine.

Precondition

® Machine configurations are available in the machine overview.

® You need a license to be able to use the entire range of functions. Information on
function restrictions can be found under License model (Page 58).

Starting a machine

The machine overview is open.

1. Select the required machine in the list of machine configurations.

2. Select the Machine > Start menu command.
-OR -
Right-click and select "Start" from the context menu.
-OR -
Click the arrow in the machine configuration.
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My machine

LS
e

840D sl 4.7 SP3 HF1 Q}_

The machine simulation opens with operator panel and SINUMERIK Operate
user interface, machine control panel with feedrate and spindle override and CNC
keyboard.

3. You operate SINUMERIK Operate using a mouse or a standard keyboard.

4. When operating SINUMERIK Operate, click the <HELP> key or press key <F12>
to obtain context-sensitive online help for the window and the input screens of
SINUMERIK Operate.

NOTICE

Loss of data when Sinutrain is exited in a non-scheduled fashion

If the operating system forces Sinutrain to shut down (e.g. when the current user is
logging off), then only the NCK data of the currently operating machine is backed
up. Changes to the machine settings and HMI data are lost.

Regularly run down the machine in order to avoid this data loss.

More information is provided in Section Unexpected shutdown of SinuTrain
(Page 83).

Shutting down the machine

® Select the Machine > Shut down menu command, if you wish to exit the actual
machine configuration.

You return to the machine overview.

Restarting the machine

® Select the Machine > Restart menu command, if you wish to restart the actual
machine configuration - for instance, after changing machine data.

The machine shuts down and is then immediately run up again.
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4.4 Problem handling

44.1 Unexpected shutdown of SinuTrain

In certain situations, the operating system forces all of the programs running to be
shut down, e.g.:

e When the current user is logging off.
® For a computer warm start after an update.

If SinuTrain is running and a machine was started at this point in time, then the data
associated with the started machine are only partially backed up, and SinuTrain is
exited.

Backed up data

NOTICE
Data loss

As SinuTrain must be exited as quickly as possible by the operating system, only
the NCK data of the started machine are backed up. Changes to the HMI data are
not saved.

To backup all data, you must regularly run down the machine.

Data that is backed up: Data that is not backed up:
e NCK data e All newly added user data in the HMI
directory
e Changed HMI settings, e.g. the HMI
language

Restoring data

The NCK data of the machine involved is automatically restored as soon as the user
involved logs on again, calls SinuTrain and starts the machine.

The required HMI settings must be manually changed.
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442 SinuTrain for SINUMERIK Operate Trace

The SinuTrain for SINUMERIK Operate Trace program offers the option of starting a
log of the next SinuTrain session. All events, sequences and messages/signals are
recorded, which are relevant for troubleshooting.

Starting the NC program

The SinuTrain for SINUMERIK Operate Trace program is installed in the program
directory of SinuTrain. The standard path is C:\Program Files
(x86)\Siemens\SinuTrain\SinuTrain Workbench\ . Double click to start the program.

Click on the "Activate" button to start the recording.

@ SinuTrain for SINUMERIK Operate Trace ]
Output path C:\Templsinu |_|

1 | | Retain number of traces

Note
You can only activate and deactivate the function if SinuTrain was first exited.
The trace settings can only be changed if the function is deactivated.

Archiving data

After starting SinuTrain for SINUMERIK Operate Trace you can freely select the
archiving directory for the trace files.

Each time that SinuTrain is started, a subdirectory with date and time in the name is
created there, in which the actual trace file is saved.

It can be helpful to analyze several trace files simultaneously when it comes to
clarifying a problem. This is why the number of saved protocols can be freely
selected, however, the number of files is limited to a maximum of 20.
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Note

Changes to the settings to archive trace files only become effective when SinuTrain
is started the next time.

This means that if an already existing trace history is reduced, the number of traces
is kept until SinuTrain for SINUMERIK Operate Trace is activated and SinuTrain was
started.

Example

12 subdirectories with trace files already exist. The number of traces is reduced to 3.
SinuTrain for SINUMERIK Operate Trace is activated, and SinuTrain started.

The 10 oldest trace files are deleted, and a new subdirectory is created. When exiting
SinuTrain precisely 3 traces exist.
System data

In specific situations, the hotline requires the system data of the user PC when
analyzing faults — for example, processor performance or the utilization level of the
work memory. The "Display system data" button is provided for this purpose.

4.4.3 Creating a trace

Should problems occur while working with SinuTrain, you have the capability of
creating atrace.

To do this, activate the "SinuTrain for SINUMERIK Operate Trace (Page 84)" tool.
The tool then logs all of the actions and events of the next SinuTrain session in a text
file, which you then send to the hotline for analysis.

General conditions

The trace tool can only be activated or deactivated when SinuTrain is not running.

Procedure
1. Ensure that SinuTrain is not running.

2. Navigate to the installation directory (default path: "C:\Programs
(x86)\SIEMENS\SinuTrain") and open the "SinuTrain Workbench" folder.
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3.

N o g k&

8.

Double-click the file "sinutraintrace.exe".
The tool "SinuTrain for SINUMERIK Operate Trace" is opened.
"Storage path" shows the path to the folder in which the trace file is saved.

Note
Changing the save location

Click on the "..." button and navigate to the desired save location. Click on the
"Create new folder" button, assign a name, and click on the "OK" button.

The selected storage path is saved.

Click the "Activate" button.
Start SinuTrain and reproduce the steps that led to the problem.
Switch to the trace tool and click on the open "Trace folder" button.

Copy the file "sitrace.txt" that was saved in the folder and send it via e-mail to
Technical Support (Page 51) for analysis.

If you want to deactivate the trace tool, you must first close SinuTrain beforehand.

Note
Information on system data

With the aid of the "Display system data" button, you have the capability of displaying
information about the operating system, the processors, and the current memory
allocation. Using the "Copy system data to the clipboard" button, save this data to the
clipboard for forwarding to the hotline.
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5 Additional documentation

5.1 Operating Manual and training instructions

When using SinuTrain, you have the option of using the context-sensitive online help
of SINUMERIK Operate via the HELP key.

Furthermore, additional and more in depth operating manuals and training
documents are available in six languages (German, English, French, Italian, Spanish,
simplified Chinese).

Note

If a particular foreign language version of a document is not available, then as an
alternative, the English edition is available.

Operating Manuals and Training Documents
e FEasy milling with ShopMill
— Milling basics
— Handling the program
— Step-by-step instructions for programming and machining various examples

® Turning made easy with ShopTurn
— Turning basics
— Handling the program
— Step-by-step instructions for programming and machining various examples
e Milling
— Detailed operating manual for SINUMERIK Operate on SINUMERIK 840D
sl/828D, milling version.
® Turning
— Detailed operating manual for SINUMERIK Operate on SINUMERIK 840D
sl/828D, turning version.
® Universal
— Detailed Operating Manual for SINUMERIK Operate on SINUMERIK 840D sl,
Universal version (without cycles description).
® Basic Functions
— Detailed Function Manual with a description of basic SINUMERIK functions.
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® Programming Manual, Fundamentals

— Programming Manual for users with a basic knowledge about drilling, milling
and turning.

— Simple programming examples that also explain commands and operations
according to DIN 66025.
® Programming Manual Advanced
— Detailed Programming Manual with a description of all parameters.

® Function Manual ISO Dialects
— Description for the commissioning and execution option of part programs
belonging to external CNC systems.
® Programming Manual, ISO milling

— Detailed description of the special issues when programming in the 1ISO
mode, milling version.

Programming Manual, ISO turning

— Detailed description of the special features when programming in the ISO
mode, turning version.
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A Appendix

A.l Menu commands

The following menu commands are available to operate SinuTrain:

m SinuTrain for SINUMERIK Operate
SIEMENS

Menu Menu commands

Function

File New From a template...

Changes to the "Create new machine -
Use template" window to create a new
machine.

From a setup
archive...

Changes to the "Create new machine -
Read setup archive" window to create a
new machine.

Copying and inserting

Copies the machine selected in the
machine overview and inserts it in the
list of machines.

You then change the properties of the
copied machine via the Machine >
Settings... menu command or the
"Settings..." command in the shortcut
menu.

Delete Deletes the selected SinuTrain
machine.
Import... Changes to the "Create new machine -

Import machine" window to transfer
stored and saved machines to the
machine overview.
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Menu

Menu commands

Function

Export...

Opens the "Save as" dialog to store and
save machine configurations from the
machine overview.

Print settings...

Switches to the "Print settings" window.

Here you define the margins and print
range and select the representation
type of the NC programs for printing.

Print...

Prints programs corresponding to what
has been defined in "Print settings" from
the SINUMERIK Operate editor.

Note:
Only active for started machines.

Exit

Exits SinuTrain for SINUMERIK
Operate.

Machine

Start

Starts the machine configuration
selected in the machine overview.

Restart

Shuts down the SinuTrain machine and
then restarts it automatically.

Shut down

Shuts down the SinuTrain machine.
The machine overview remains open.

Settings...

Changes to the "Edit machine" window
in order to change the machine name,
description, language and machine
image as well as the resolution of the
SINUMERIK Operate user interface.

Extras

Install additional HMI

Changes to the "Install additional HMI

languages... languages" window in order to install
additional available languages for
SINUMERIK Operate.

Options... Changes to the "Options" window to

make the following settings:

e Selection of the language for the
SinuTrain user interface

¢ Activation or deactivation of
messages in SinuTrain for
SINUMERIK Operate (e.g. message
regarding possible data loss when
deleting a SinuTrain machine)

90

Training and Programming
ABE38756522, 07/2016



Appendix

Menu Menu commands Function

Window Split into single windows Splits the machine simulation window
into 3 individual windows that can be
moved:

¢ SINUMERIK Operate user interface

e Controls of an operator panel

e Machine control panel with feedrate
and spindle override

Note:

Only active once the machine has been

started.

Help Help on SinuTrain... Opens the online help for SinuTrain for
SINUMERIK Operate.

Help on SINUMERIK CNC- | Opens the online help for release-
SW specific information.

The submenus depend on the installed
CNC software versions.

Info... Changes to the "About SinuTrain for
SINUMERIK Operate" window to obtain
the following information:

e Product version of the installed
SinuTrain for SINUMERIK Operate

¢ Data of the versions of all CNC
software packages in the "Installed
SINUMERIK CNC SW packages"
area
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A.2 Context menu

There is a context menu with the following commands for each machine page in the

machine overview:

Menu commands

Function

Start

Starts the machine configuration selected in the machine
overview.

Export...

Opens the "Save as" dialog to export machine
configurations from the machine overview.

Copying and inserting

Copies the machine selected in the machine overview and
inserts it in the list of machines.

You then change the properties of the copied machine via
the Machine > Settings... menu command or the
"Settings..." command in the context menu.

Delete

Deletes the selected SinuTrain machine.

Settings...

Changes to the "Edit machine" window in order to change
the machine name, description, language and machine
image as well as the resolution of the SINUMERIK
Operate user interface.
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A.3 Operation with standard PC keyboard

The following keys and key combinations are available for operation of SinuTrain

SINUMERIK Operate.

PC keyboard

Function

<F1> ... <F8>

Horizontal softkeys 1 to 8

Shift + <F1> ... <F8>

Vertical softkeys 1 to 8

<F9>

AN

Shift + <F9>
<F10>
MENU
SELECT
Shift + <F10> —
M,
MACHINE
<F11> 1.0
CHANNEL
<F12> @
HELP
<Paget>
=
PAGE
up
<Page !>
=
PAGE
DOWN
<Enter>

INPUT
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PC keyboard

Function

<Insert>

>

INSERT

Numerical block <5>

O

SELECT

<Esc> =
<
ALARM
CANCEL
<Ctrl> + <Alt> + <Shift> + <1>
MWV
UL

JOG

<Ctrl> + <Alt> + <Shift> + <2>

The operational SinuTrain machine is run down.

<Ctrl> + <Alt> + <Shift> + <3>

9

RESET

<Ctrl> + <Alt> + <Shift> + <4>

CYCLE
START

<Ctrl> + <Alt> + <Shift> + <5>

CYCLE
STOP

<Ctrl> + <Alt> + <Shift> + <6>

MDA

<Ctrl> + <Alt> + <Shift> + <7>

B)

SINGLE
BLOCK

<Ctrl> + <Alt> + <Shift> + <8>

AUTO

94

Training and Programming
ABE38756522, 07/2016



Index

A

Additional documents, 80
Automation License Manager, 52

D
DEMO machines, 52

L

License model, 52
Licensing, 51

M

Machine
configuring, 66
copying, 66
creating, 64
creating from setup archive, 70
creating from template, 64
deleting, 73
exporting, 72
importing, 67
restarting, 76
Settings, 71
shutting down, 76
starting, 75

Machine configurations
managing, 57

Machine overview, 57

Menu commands, 81

Training and Programming
ABE38756522, 07/2016

N

NC programs

P

printing, 73

PC keyboard, standard, 85
Print, 73
Printout

S

Layout, 74

Settings

For machine, 71

SINUMERIK Operate, 51

changing language, 62
Context-sensitive online help, 76
installing additional languages, 60

SinuTrain

changing language, 61
exiting, 63

General sequence, 56
installing, 54

Languages, 60

Machine overview, 57
starting, 62

System requirements, 53
uninstalling, 56

User interface, 59

System requirements

SinuTrain, 53

95



Index

Siemens AG

Division Digital Factory
Postfach 48 48

90026 NURNBERG
GERMANY

Training and Programming
ABE38756522, 07/2016






Siemens AG Anderungen vorbehalten
Digital Factory A5E38756522

Motion Control © Siemens AG 2016
Postfach 3180

91050 Erlangen

DEUTSCHLAND

www.siemens.com/automation




	1 Übersicht
	2 Lizenzierung mit Automation License Manager
	3 Lizenzmodell
	4 SinuTrain for SINUMERIK Operate
	4.1 SinuTrain installieren / deinstallieren
	4.1.1 Systemvoraussetzungen
	4.1.2 SinuTrain installieren
	4.1.3 SinuTrain deinstallieren

	4.2 SinuTrain bedienen
	4.2.1 So funktioniert SinuTrain
	4.2.2 Maschinenübersicht
	4.2.3 Bildschirmeinteilung der Maschinensimulation
	4.2.4 Sprachen installieren
	4.2.4.1 Zusätzliche Sprachen für SinuTrain installieren
	4.2.4.2 Zusätzliche Sprachen für SINUMERIK Operate installieren

	4.2.5 SinuTrain-Sprache ändern

	4.3 Mit SinuTrain arbeiten
	4.3.1 SinuTrain starten und beenden
	4.3.2 Maschine anlegen
	4.3.2.1 Übersicht
	4.3.2.2 Maschine aus Vorlage erstellen
	4.3.2.3 Maschine kopieren und konfigurieren
	4.3.2.4 Maschine importieren
	4.3.2.5 Maschine aus Inbetriebnahmearchiv erstellen

	4.3.3 Maschineneinstellungen ändern
	4.3.4 Maschinenkonfiguration exportieren
	4.3.5 Maschine löschen
	4.3.6 Programm ausdrucken
	4.3.7 Maschine starten und herunterfahren

	4.4 Problembehandlung
	4.4.1 Unerwartetes Beenden von SinuTrain
	4.4.2 SinuTrain for SINUMERIK Operate Trace
	4.4.3 Trace erstellen


	5 Ergänzende Dokumentationen
	5.1 Bedienhandbücher und Trainingsanleitungen
	A Anhang

	A.1 Menübefehle
	A.2 Kontextmenü
	A.3 Bedienung mit PC-Standardtastatur

	1 Overview
	2 Licensing using the Automation License Manager
	3 License model
	4 SinuTrain for SINUMERIK Operate
	4.1 Installing / uninstalling SinuTrain
	4.1.1 System requirements
	4.1.2 Installing SinuTrain
	4.1.3 Uninstalling SinuTrain

	4.2 Operating SinuTrain
	4.2.1 This is how SinuTrain functions
	4.2.2 Machine overview
	4.2.3 Screen layout of the machine simulation
	4.2.4 Installing languages
	4.2.4.1 Installing additional languages for Sinutrain
	4.2.4.2 Installing additional languages for SINUMERIK Operate

	4.2.5 Changing the SinuTrain language

	4.3 Working with SinuTrain
	4.3.1 Starting and exiting SinuTrain
	4.3.2 Creating a machine
	4.3.2.1 Overview
	4.3.2.2 Creating a machine from a template
	4.3.2.3 Copying and configuring a machine
	4.3.2.4 Importing a machine
	4.3.2.5 Creating a machine from the start-up archive

	4.3.3 Changing machine settings
	4.3.4 Exporting a machine configuration
	4.3.5 Deleting a machine
	4.3.6 Printing-out a program
	4.3.7 Starting and shutting down a machine.

	4.4 Problem handling
	4.4.1 Unexpected shutdown of SinuTrain
	4.4.2 SinuTrain for SINUMERIK Operate Trace
	4.4.3 Creating a trace


	5 Additional documentation
	5.1 Operating Manual and training instructions
	A Appendix

	A.1 Menu commands
	A.2 Context menu
	A.3 Operation with standard PC keyboard


